Bug 988296 - rfe: allow a list of urls for the handle.url parameter
rfe: allow a list of urls for the handle.url parameter
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: librepo (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Mlcoch
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1002508
  Show dependency treegraph
 
Reported: 2013-07-25 05:19 EDT by Ales Kozumplik
Modified: 2014-09-30 19:41 EDT (History)
2 users (show)

See Also:
Fixed In Version: librepo-1.0.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 21:28:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ales Kozumplik 2013-07-25 05:19:13 EDT
Description of problem:

h.url = [URL]

currently causes an exception:

TypeError: Only string or None is supported with this option

The reason why I'd want this is that sometimes we know multiple URLs for a given repo (e.g. we resolved them from a mirrorlist through some other means) and if handle accepts only one url which is currently down it will fail we have to micromanage around it by creating new handle with the next url and retrying the operation.
Comment 1 Tomas Mlcoch 2013-08-12 04:18:39 EDT
Fix was pushed to the master branch https://github.com/Tojaj/librepo/commit/0fbe1c3b96f21c87a6ad1c0ec7fd3ec4c6b05cad
Comment 2 Ales Kozumplik 2013-08-16 07:18:40 EDT
Thanks Tomas.

Do you plan to make a build with this patch for both F19 and rawhide? Let's coordinate the date on that.
Comment 3 Fedora Update System 2013-09-03 04:47:05 EDT
librepo-1.0.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/librepo-1.0.0-1.fc19
Comment 4 Fedora Update System 2013-09-03 18:31:42 EDT
Package librepo-1.0.0-1.fc19, dnf-0.3.11-2.git54f55e0.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing librepo-1.0.0-1.fc19 dnf-0.3.11-2.git54f55e0.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15734/dnf-0.3.11-2.git54f55e0.fc19,librepo-1.0.0-1.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-04 21:28:31 EDT
librepo-1.0.0-1.fc19, dnf-0.3.11-2.git54f55e0.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.