This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 98830 - Faroese keyboard layout in XFree86.
Faroese keyboard layout in XFree86.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
http://bugs.xfree86.org/cgi-bin/bugzi...
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-09 07:42 EDT by Roi a Torkilsheyggi
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-01 06:38:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Roi a Torkilsheyggi 2003-07-09 07:42:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030530

Description of problem:
The Faroese keyboard layout just recently got included in XFree86, and thus
isn't included in RedHat 9.

------ from bugreport on XFree86-----------------

I've managed by (on RH5 to RH8) copying and changing the danish files
dk-latin1.map.gz and dk),and renaming them to 'fo'. But I'm not able to perform
my the usual 'hacks' on RH9.

The big differance is the letter '�', shifted '�' (eth and ETH in html, e.g.
ð). This letter is available in the danish layout, but one has to use ALT -D
to type it. People are used to having it on the right to the letter '�' (which
is on the right of 'p').

To put it as simple as possible, make a new layout (based on the danish) that
has eth/ETH as the regular/shifted letter on 'key <AD12>'.
I moved dead_diaeresis and dead_circumflex to <AD11> so they wouldn't just vanish.

I'm submitting this bug because changing the Danish files does not work on
RedHat 9. I'm no longer able to set it up myself, but I'm hoping that it will be
included in XFree86 and thus be made available in Linux distributions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. (Red fields are required) Install RedHat 9, choose Faroese as default
language (no Faroese keyboard layout available).
2. Check that although the names of weekdays and months are in Faroese, there's
no way to choose to use a Faroese keyboard.
3. Acknowledge that there indeed is no Faroese keyboard layout.
    

Additional info:
Comment 1 Mike A. Harris 2003-07-14 18:44:33 EDT
Red Hat ships what comes with XFree86.  Red Hat Linux 9, ships with XFree86
4.3.0, and so the keymaps available are what comes with XFree86 4.3.0.  There
does not appear to be a Faroese keymap layout in that release, and so it is not
supported by XFree86 4.3.0 or Red Hat Linux 9.

The proper way to get new keymaps supported, is to contact XFree86.org directly
via their bugzilla located at http://bugs.xfree86.org and submit a request to
have a keymap added (or keymap bugfix, etc..) to them.  XFree86.org has people
whom are an expert in this area, and whom can review the submission and decide
wether to include it, reject it, or modify and include it.  Once the keymap
is included in XFree86 CVS, it will get into the next XFree86 release, and
the next version of Red Hat Linux which ships the new version of XFree86 will
include support for that keymap, etc.

Depending on how large the changes are, regression risk, and time and
engineering resources are available, such changes, if minimal and low risk,
may also be backported from CVS to the current XFree86 release, and may be
included in future Red Hat Linux erratum.

I'm changing this request from a bug report, to a request for enhancement,
and setting it's status to upstream.  Please report this issue upstream, or
if you have allready, please provide the URL to the upstream bug report.

Once the changes are in XFree86 CVS, I can examine them and consider them
for inclusion in future Red Hat Linux XFree86 builds.

Thanks.
Comment 2 Mike A. Harris 2003-07-17 04:46:37 EDT
Please update report with upstream request URL, so it can be tracked.

Thanks in advance.
Comment 3 Mike A. Harris 2004-09-01 06:38:21 EDT
Upstream bug report indicates this issue is fixed in Jun 2003
in XFree86 CVS.  We're using a codebase which is derived from
that currently (X.Org X11), so this issue should be fixed in
our current rawhide xorg-x11.

Setting status to "RAWHIDE"

Note You need to log in before you can comment on or make changes to this bug.