Bug 988302 - [virtio-win][netkvm]Register NetSH failed on 32 bit guest
[virtio-win][netkvm]Register NetSH failed on 32 bit guest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 05:26 EDT by Min Deng
Modified: 2013-12-06 03:05 EST (History)
9 users (show)

See Also:
Fixed In Version: virtio-win-prewhql-0.1-67
Doc Type: Bug Fix
Doc Text:
Cause: Drivers and drivers' components are built now with Visual Studio. This is due to the change in Windows 8 DDK that had removed command line build tools from DDK. Old "source" files (similar to make files) where converted to Visual Studio projects. Automatic conversion set wrong calling convention for 32bit binaries of the netsh plugin that we are building and therefore it couldn't be registered with netsh and used. Consequence: All netsh plugin command line options where unusable on 32bit OSes. Fix: Change the calling convention. Result: netsh plugin is usable again. Please refer to readme.doc in the driver package directory for its usage.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 19:14:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Min Deng 2013-07-25 05:26:53 EDT
Description of problem:
Register NetSH failed on win7-32 guest.

Version-Release number of selected component (if applicable):
build 65 
on rhel7 host 
qemu-kvm-1.5.1-2.el7.x86_64
seabios-1.7.2.2-2.el7.x86_64
seavgabios-bin-1.7.2.2-2.el7.noarch
vgabios-0.6c-9.el7.noarch
Besides,it can also be reproduced on rhel6 host.

How reproducible:
5 times

Steps to Reproduce:
1.boot up guest with the following 
  /usr/libexec/qemu-kvm -smp 4 -m 2G -device virtio-balloon-pci,id=balloon0 -k en-us -usb -device usb-tablet,id=tablet0 -device intel-hda,id=sound0 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -drive file=/home/win732.qcow3,format=qcow2,cache=none,if=none,werror=stop,rerror=stop,id=drive-disk0,media=disk,cache=writethrough,serial=systemdisk -device ide-drive,drive=drive-disk0,id=disk0,bootindex=2 -netdev tap,id=hostnet0,vhost=on,script=/etc/qemu-ifup -device virtio-net-pci,netdev=hostnet0,id=net0,mac=00:11:41:54:33:8a -spice port=5931,disable-ticketing -vga qxl -uuid ad4c1a2b-4fba-43c5-a7f5-50297cc885c1 -monitor stdio -drive file=NFS.qcow3,if=none,format=qcow2,id=drive-virtio-data1,werror=stop,rerror=stop,cache=writeback -device virtio-blk-pci,id=virtio-data1,drive=drive-virtio-data1 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -cdrom en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso
2.in win7-32 guest
  .Registration in NetSH (instllation):

   1).cmd --> run as administrator

   2).cd path-to-the-netkvm-driver  (installation file)

   3).rundll32 netkvmco.dll,RegisterNetKVMNetShHelper

Actual results:
It failed at step 2.3 
An error message popped up

******************************************
*Error in netkvmco.dll                   * 
*Missing entry:RegisterNetKVMNetShHelper *
******************************************

Expected results:
Register successfully.


Additional info:
don't reproduced on win7-64/win2k8-R2,please double check the issue,thanks
Comment 2 Vadim Rozenfeld 2013-07-25 06:11:29 EDT
Hi Min,
Could you please check how it works in build 62 and 64?
You don't need to install the drivers, just grab netkvmco.dll from
these builds and try running them.

Thank you.
Vadim.
Comment 3 Mike Cao 2013-07-25 06:14:45 EDT
(In reply to Vadim Rozenfeld from comment #2)
> Hi Min,
> Could you please check how it works in build 62 and 64?
> You don't need to install the drivers, just grab netkvmco.dll from
> these builds and try running them.
> 
> Thank you.
> Vadim.

I tried build49 ,still hit this issue on win7-32 bit guests ,can not trigger it on win7-64 .
Comment 4 Yan Vugenfirer 2013-07-30 05:39:38 EDT
This functionality is must for server OSes only. Can be moved to lower priority.
Comment 5 lijin 2013-07-30 06:44:48 EDT
(In reply to Yan Vugenfirer from comment #4)
> This functionality is must for server OSes only. Can be moved to lower
> priority.

retest on win2k8-32 guest,still hit this issue.
Comment 6 Mike Cao 2013-07-30 06:50:30 EDT
Move back to rhel6.5.0 according to comment #5
Comment 7 Mike Cao 2013-07-31 22:42:15 EDT
According to comment #4 ,add test blocker flag
Comment 9 Mike Cao 2013-08-22 05:07:59 EDT
dengmin ,pls verify it on virtio-win-prewhql-67
Comment 10 Min Deng 2013-08-23 06:15:00 EDT
Reproduced the bug on build 65 
Verified it on build 67,please refer to the detail steps from comment0
Actual results,there is no any error message.
Expected results,there is no any error message.

Base on above test results,the issue has been fixed,thanks.
Comment 11 Mike Cao 2013-08-26 03:11:45 EDT
Move status to VERIFIED according to comment #10
Comment 13 errata-xmlrpc 2013-11-21 19:14:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1729.html

Note You need to log in before you can comment on or make changes to this bug.