This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 98832 - kudzu breaks network card
kudzu breaks network card
Status: CLOSED DUPLICATE of bug 107389
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kudzu (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-09 08:15 EDT by Alexander Larsson
Modified: 2014-03-16 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
modules.conf (47 bytes, text/plain)
2003-07-09 08:33 EDT, Alexander Larsson
no flags Details
ifcfg-eth0 (96 bytes, text/plain)
2003-07-09 08:33 EDT, Alexander Larsson
no flags Details
ifcfg-lo (254 bytes, text/plain)
2003-07-09 08:33 EDT, Alexander Larsson
no flags Details
hwconf (2.72 KB, text/plain)
2003-07-09 08:59 EDT, Alexander Larsson
no flags Details

  None (edit)
Description Alexander Larsson 2003-07-09 08:15:54 EDT
Kudzu 1.1.9-1 breaks my 3Com 3c590 NIC if its loaded before the network is
initialized. If I boot in single-user mode, ifup eth0 and then switch to
runlevel 5 it works though. 

When the card is "broken", it doesn't send packets on the network, and doesn't
recieve *any* packets except locally sent packets and an occational packet with
bad crc.

This is independent of kernel. I tried the RH9 kernel, and it did the same thing.
Comment 1 Bill Nottingham 2003-07-09 08:27:34 EDT
Can you post your modules.conf and /etc/sysconfig/network-scripts/ifcfg-*?
Comment 2 Alexander Larsson 2003-07-09 08:33:25 EDT
Created attachment 92824 [details]
modules.conf
Comment 3 Alexander Larsson 2003-07-09 08:33:44 EDT
Created attachment 92825 [details]
ifcfg-eth0
Comment 4 Alexander Larsson 2003-07-09 08:33:59 EDT
Created attachment 92826 [details]
ifcfg-lo
Comment 5 Bill Nottingham 2003-07-09 08:41:57 EDT
Can you post your /etc/sysconfig/hwconf? In the case where it doesn't work, what
are the kernel messges from the driver, if any?
Comment 6 Alexander Larsson 2003-07-09 08:59:44 EDT
Created attachment 92827 [details]
hwconf
Comment 7 Alexander Larsson 2003-07-09 09:01:07 EDT
no driver messages
Comment 8 Bill Nottingham 2003-07-09 09:15:39 EDT
No driver messages at all? Not even on initialization?
Comment 9 Alexander Larsson 2003-07-09 09:40:48 EDT
Well. The normal initialization messages are there:
Jul  9 14:03:27 testbox kernel: PCI: Found IRQ 10 for device 00:0b.0
Jul  9 14:03:27 testbox kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Jul  9 14:03:27 testbox kernel: See Documentation/networking/vortex.txt
Jul  9 14:03:27 testbox kernel: 00:0b.0: 3Com PCI 3c590 Vortex 10Mbps at 0xa400.
Vers LK1.1.18-ac
Jul  9 14:03:28 testbox kernel: 00:0b.0: Overriding PCI latency timer (CFLT)
setting of 32, new value is 248.
Jul  9 14:03:28 testbox kernel:  00:20:af:f2:b7:18, IRQ 10
Jul  9 14:03:28 testbox kernel:   product code 4243 rev 00.0 date 08-22-95
Jul  9 14:03:28 testbox kernel:   32K byte-wide RAM 1:1 Rx:Tx split,
autoselect/10baseT interface.
Jul  9 14:03:28 testbox kernel: 00:0b.0: scatter/gather disabled. h/w checksums
disabled
Jul  9 14:03:28 testbox kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jul  9 14:03:28 testbox kernel: PCI: Found IRQ 10 for device 00:0b.0
Jul  9 14:03:28 testbox kernel: 3c59x: Donald Becker and others.
www.scyld.com/network/vortex.html
Jul  9 14:03:28 testbox kernel: See Documentation/networking/vortex.txt
Jul  9 14:03:28 testbox kernel: 00:0b.0: 3Com PCI 3c590 Vortex 10Mbps at 0xa400.
Vers LK1.1.18-ac
Jul  9 14:03:28 testbox kernel:  00:20:af:f2:b7:18, IRQ 10
Jul  9 14:03:28 testbox kernel:   product code 4243 rev 00.0 date 08-22-95
Jul  9 14:03:28 testbox kernel:   64K word-wide RAM 1:1 Rx:Tx split,
autoselect/10baseT interface.
Jul  9 14:03:28 testbox kernel: 00:0b.0: scatter/gather disabled. h/w checksums
disabled
Jul  9 14:03:28 testbox kernel: ip_tables: (C) 2000-2002 Netfilter core team

Actually it seems that they are reported twice every time the NIC breaks... That
may be related.
Comment 10 Bill Nottingham 2003-07-09 15:17:59 EDT
Hm, I installed kudzu-1.1.9-1, and put a craptastic 3c990 10Mb card in my box.
It works fine with kudzu running.
Comment 11 Alexander Larsson 2003-07-09 15:45:56 EDT
strange...
Comment 12 Bill Nottingham 2003-07-31 00:15:46 EDT
I'm assuming this didn't spontaneously start working with newer kernels?
Comment 13 Alexander Larsson 2003-08-05 09:58:03 EDT
Nope. Just installed the latest tree and got the same thing. 
Comment 14 Bill Nottingham 2004-02-04 01:36:06 EST

*** This bug has been marked as a duplicate of 107389 ***
Comment 15 Red Hat Bugzilla 2006-02-21 13:56:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.