Bug 988354 - nic->network assignement not working for VM created from template with disk
nic->network assignement not working for VM created from template with disk
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-webadmin (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3
Assigned To: Tomas Jelinek
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 07:45 EDT by Tomas Jelinek
Modified: 2013-11-27 05:02 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 05:02:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 18607 None None None Never

  None (edit)
Description Tomas Jelinek 2013-07-25 07:45:11 EDT
Create a VM from template with big disk and couple of nics. In
new vm dialog edit the nic->network assignment. Press OK.

It will fail with:
2013-07-25 13:16:45,715 WARN  [org.ovirt.engine.core.bll.network.vm.UpdateVmInterfaceCommand] (http--0.0.0.0-8080-1) [70beffb3] CanDoAction of action UpdateVmInterface failed. Reasons:VAR__TYPE__INTERFACE,VAR__ACTION__UPDATE,NETWORK_CANNOT_CHANGE_STATUS_WHEN_NOT_DOWN_UP
  
The problem:
First the AddVmFromTemplate is called. After it returns the
UpdateVmInterfaceCommand is called to edit the nic->network
assignment.

The problem is that the VM status can be "image locked" which
prevents the nic editing.

Note You need to log in before you can comment on or make changes to this bug.