Bug 988389 - Mapnik (2.0.0-13.fc19) not compatible with current PostGIS (2.0.3-1.fc19)
Mapnik (2.0.0-13.fc19) not compatible with current PostGIS (2.0.3-1.fc19)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mapnik (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 09:32 EDT by Paulius Zaleckas
Modified: 2013-08-07 19:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: mapnik-2.0.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 19:07:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paulius Zaleckas 2013-07-25 09:32:15 EDT
When generating map from OSM data I get following errors:

Exception in thread Thread-1:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 811, in __bootstrap_inner
    self.run()
  File "/usr/lib64/python2.7/threading.py", line 764, in run
    self.__target(*self.__args, **self.__kwargs)
  File "./generate_tiles.py", line 116, in loop
    self.render_tile(tile_uri, x, y, z)
  File "./generate_tiles.py", line 98, in render_tile
    mapnik.render(self.m, im)
RuntimeError: :
ERROR:  function asbinary(geometry) does not exist
LINE 1: SELECT AsBinary("way") AS geom,"name","place" from 
               ^
HINT:  No function matches the given name and argument types. You might need to add explicit type casts.
Full sql was: 'SELECT AsBinary("way") AS geom,"name","place" from 
      (select way,place,name,ref
       from planet_osm_point
       where place in ('country','state')
      ) as placenames WHERE "way" && SetSRID('BOX3D(-20037508 -15028131.25709193,-5009377.08569731 5009377.08569731)'::box3d, 900913)'

AFAIK PostGIS renamed AsBinary to ST_AsBinary. So we need to fix Mapnik or use Mapnik 2.2.x which already has this fix.
Comment 1 Paulius Zaleckas 2013-07-25 09:40:08 EDT
Mapnik 2.0.2 also has needed fixes for PostGIS 2.0 support.
Comment 2 Tom Hughes 2013-07-25 10:52:26 EDT
We already have 2.2.0 in rawhide (I assume that is what you meant by 2.0.2) but because there are significant changes required to other packages (mainly agg) I am reluctant to try and push such a major update into the current release versions of Fedora.
Comment 3 Paulius Zaleckas 2013-07-25 10:59:36 EDT
No, by 2.0.2 I mean 2.0.2 :D
I hope 2.0.2 does not require these significant changes as 2.2.0 does...
Comment 4 Tom Hughes 2013-07-25 11:04:54 EDT
Well if 2.0.2 is enough to fix the postgis issue then I'll have a look at whether we can build that into F18/19 next week.
Comment 5 Paulius Zaleckas 2013-07-25 11:06:33 EDT
Yes, 2.0.2 should be enough.
Comment 6 Tom Hughes 2013-07-28 13:29:17 EDT
I've done a scratch build of 2.0.2 at http://koji.fedoraproject.org/koji/taskinfo?taskID=5667816 if you'd like to check that it fixes your problem?
Comment 7 Paulius Zaleckas 2013-07-29 03:40:23 EDT
Works fine. Thank you!
Comment 8 Fedora Update System 2013-07-29 09:04:36 EDT
mapnik-2.0.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mapnik-2.0.2-2.fc19
Comment 9 Fedora Update System 2013-07-30 13:43:05 EDT
Package mapnik-2.0.2-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mapnik-2.0.2-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-13881/mapnik-2.0.2-2.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-08-07 19:07:18 EDT
mapnik-2.0.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.