Bug 988411 - Name change for AT-SPI locator "Providing Subscriptions"
Name change for AT-SPI locator "Providing Subscriptions"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 6.5
Assigned To: Carter Kozak
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-07-25 10:43 EDT by Sharath Dwaral
Modified: 2013-11-21 16:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:26:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
At-SPI locator name change for maintaining consistency (96.93 KB, image/png)
2013-07-25 10:43 EDT, Sharath Dwaral
no flags Details
At-SPI locator name change for maintaining consistency (92.78 KB, image/png)
2013-07-25 11:40 EDT, Sharath Dwaral
no flags Details
firstboot-AT-SPI (97.54 KB, image/png)
2013-07-30 16:07 EDT, Sharath Dwaral
no flags Details
Fixed AT-SPI locators (267.97 KB, image/png)
2013-09-05 16:15 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Sharath Dwaral 2013-07-25 10:43:06 EDT
Created attachment 778287 [details]
At-SPI locator name change for maintaining consistency

Description of problem:
Requiring a name change for AT-SPI locator in subscription-manager-gui to maintain consistency and help in GUI automation

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-debuginfo-1.8.13-1.el5
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
python-rhsm-1.8.14-1.git.1.1ba97bb.el5
subscription-manager-firstboot-1.8.13-1.git.34.3855d08.el5
subscription-manager-1.8.13-1.git.34.3855d08.el5
subscription-manager-migration-1.8.13-1.git.34.3855d08.el5
subscription-manager-gui-1.8.13-1.git.34.3855d08.el5
python-rhsm-debuginfo-1.8.13-1.el5

How reproducible:
always

Steps to Reproduce:
Open GUI
Open Sniff (AT-SPI locator 'yum install dogtail')
(See Attachment)

Actual results:
Providing Subscriptions

Expected results:
Providing Subscriptions Text

Additional info:
This will not affect String change and the change can be implemented into 5.10
Comment 1 Sharath Dwaral 2013-07-25 11:40:24 EDT
Created attachment 778334 [details]
At-SPI locator name change for maintaining consistency

AT-SPI locators require name change (See Attachment)

Version:
Same as above
Comment 2 Carter Kozak 2013-07-25 17:02:40 EDT
fix for Provides, I'll do the rest tomorrow

commit 4dad7fbb09982e626520e72363553a39c1b61231
Author: ckozak <ckozak@redhat.com>
Date:   Thu Jul 25 10:26:58 2013 -0400

    988411: fixed at-spi locator name
Comment 3 Sharath Dwaral 2013-07-30 16:07:39 EDT
Created attachment 780829 [details]
firstboot-AT-SPI

# rpm -qa | grep subscription-manager
subscription-manager-firstboot-1.8.14-1.el5
subscription-manager-migration-data-1.11.3.1-1.git.1.78afd75.el5
subscription-manager-debuginfo-1.8.14-1.el5
subscription-manager-1.8.14-1.el5
subscription-manager-gui-1.8.14-1.el5
subscription-manager-migration-1.8.14-1.el5


AT-SPI locators needed (See Attachment)
Comment 5 Carter Kozak 2013-08-05 11:20:25 EDT
Most of them are merged, can you open a new bug for the rest?

commit b1df9ad317e160bc5634ea44ccc8829a621922b3
Author: ckozak <ckozak@redhat.com>
Date:   Mon Jul 29 16:06:24 2013 -0400

    988411: more at-spi changes for QA
Comment 6 Bryan Kearney 2013-09-03 14:21:38 EDT
this is availanble in 1.9.2
Comment 7 Sharath Dwaral 2013-09-05 16:15:38 EDT
Created attachment 794496 [details]
Fixed AT-SPI locators

Version:

# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-migration-data-1.12.2.6-1.git.0.171d4c3.el6.noarch
python-rhsm-1.9.4-1.el6.x86_64
subscription-manager-firstboot-1.9.5-1.el6.x86_64
subscription-manager-gui-1.9.5-1.el6.x86_64
subscription-manager-migration-1.9.5-1.el6.x86_64
python-rhsm-debuginfo-1.9.4-1.el6.x86_64
subscription-manager-1.9.5-1.el6.x86_64

Verification:

AT-SPI locators are fixed as requested (See Attachment)

VERIFIED
Comment 8 errata-xmlrpc 2013-11-21 16:26:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.