Bug 988413 - python3-matplotlib-qt4 downloads unecessary dependencies
python3-matplotlib-qt4 downloads unecessary dependencies
Status: CLOSED DUPLICATE of bug 988412
Product: Fedora
Classification: Fedora
Component: python3 (Show other bugs)
19
i386 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Bohuslav "Slavek" Kabrda
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 10:45 EDT by Shishir
Modified: 2013-07-26 02:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 02:54:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shishir 2013-07-25 10:45:47 EDT
Description of problem: python3-matplotlib-qt4 depends on numpy and python-matplotlib. This must not be the case as python3-matplotlib should only depend on python3-numpy and python3-matplotlib. Also python3-matplotlib does not automatically pull down a dependency python3-matplotlib-tk.


Version-Release number of selected component (if applicable):


How reproducible:



Steps to Reproduce:
1.sudo yum install python3-matplotlib-qt4
2.
3.

Actual results:


=============================================================================================================================================================
 Package                                  Arch                     Version                                                   Repository                 Size
=============================================================================================================================================================
Installing:
 python3-matplotlib-qt4                   i686                     1.2.0-14.fc19                                             updates                    36 k
Installing for dependencies:
 numpy                                    i686                     1:1.7.1-2.fc19                                            fedora                    2.8 M
 pyparsing                                noarch                   1.5.6-8.fc19                                              fedora                     94 k
 python-dateutil                          noarch                   1.5-6.fc19                                                fedora                     85 k
 python-matplotlib                        i686                     1.2.0-14.fc19                                             updates                    26 M
 python-nose                              noarch                   1.3.0-1.fc19                                              fedora                    272 k
 python-setuptools                        noarch                   0.6.36-1.fc19                                             fedora                    342 k
 python3-PyQt4                            i686                     4.10.1-4.fc19                                             fedora                    2.6 M
 python3-sip                              i686                     4.14.6-1.fc19                                             fedora                     96 k
 pytz                                     noarch                   2012d-4.fc19                                              fedora                     38 k
 t1lib                                    i686                     5.1.2-12.fc19                                             fedora                    155 k
 texlive-base                             noarch                   3:2013-0.1.20130608_r30832.fc19                           updates                   1.4 M
 texlive-dvipng-bin                       i686                     3:svn30088.0-0.1.20130608_r30832.fc19                     updates                    60 k
 texlive-kpathsea-lib                     i686                     3:2013-0.1.20130608_r30832.fc19                           updates                    89 k

Transaction Summary
=============================================================================================================================================================
Install  1 Package (+13 Dependent packages)


Expected results:


Additional info:
Comment 1 Bohuslav "Slavek" Kabrda 2013-07-26 02:54:05 EDT

*** This bug has been marked as a duplicate of bug 988412 ***

Note You need to log in before you can comment on or make changes to this bug.