Bug 988428 - File preservation does not work while re-provisioning system from RHEL 5 to RHEL 6.2 or later
File preservation does not work while re-provisioning system from RHEL 5 to R...
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Clients (Show other bugs)
1.9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Stephen Herr
Red Hat Satellite QA List
:
Depends On: 917334
Blocks: space21
  Show dependency treegraph
 
Reported: 2013-07-25 11:06 EDT by Stephen Herr
Modified: 2014-03-04 08:08 EST (History)
5 users (show)

See Also:
Fixed In Version: spacewalk-koan-2.1.1-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 917334
Environment:
Last Closed: 2014-03-04 08:07:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Herr 2013-07-25 11:06:02 EDT
+++ This bug was initially created as a clone of Bug #917334 +++

Description of problem:
File preservation does not work while re-provisioning system from RHEL 5 system to RHEL 6 . 

When we try to re-provision RHEL 5 system with RHEL 6 kickstart proflie , which has file preservation enabled. Files are preserved but they are not restored back after completion of RHEL 6 installation. 


Version-Release number of selected component (if applicable):
RHN Satellite v 5.5
RHEL 5 - RHEL 6 

How reproducible:
Always

Steps to Reproduce:
1. Create RHEL 6 kickstart profile with file preservation enabled 
2. Take any RHEL 5 system which is registered to RHN Satellite v 5.5 and have Provisioning entitlement assigned. 
3. Re-provistion RHEL 5 system with same kickstart profile 
  
Actual results:

After RHEL 6 system installation , preserved files from RHEL 5 system are missing on filesystem. 

Expected results:

Preserved files should be present on RHEL 6 system after re-provisioning from RHEL 5 system. 

Additional info:

--- Additional comment from Stephen Herr on 2013-07-24 17:36:16 EDT ---

This is due to RHEL 6.2 and onwards using LZMA compression for the initrd.img instead of gzip compression. The workaround for this is to simply kickstart to RHEL 6.1 instead, and then do a 'yum update' go get on the latest packages. Alternately you can kickstart to 6.1 and then kickstart to 6.latest.

--- Additional comment from Stephen Herr on 2013-07-25 11:00:43 EDT ---

A better workaround is to install the "xz" package on the RHEL 5 system before attempting the kickstart to RHEL 6. This is really the heart of the bug; that xz is not installed by default on RHEL 5 (it is in RHEL 6) and the spacewalk-koan package does not properly depend on it.
Comment 1 Stephen Herr 2013-07-25 11:08:25 EDT
Committed to Spacewalk master:
843f1232dcc8ba9263f43f15669f184d56ed9e9d
Comment 2 Matej Kollar 2014-01-17 07:15:23 EST
Switching MODIFIED Spacewalk bugs to ON_QA before 2.1 release.
Comment 3 Matej Kollar 2014-03-04 08:07:42 EST
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21
Comment 4 Matej Kollar 2014-03-04 08:08:54 EST
Spacewalk 2.1 has been released.
https://fedorahosted.org/spacewalk/wiki/ReleaseNotes21

Note You need to log in before you can comment on or make changes to this bug.