Bug 988429 - repoquery needs to able to use a specified cache directory
repoquery needs to able to use a specified cache directory
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 985681
  Show dependency treegraph
 
Reported: 2013-07-25 11:06 EDT by Orion Poplawski
Modified: 2013-08-09 13:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: yum-utils-1.1.31-17.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-09 13:03:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
repoquery: add --installroot option. BZ 988429 (2.18 KB, patch)
2013-07-29 08:41 EDT, Zdeněk Pavlas
no flags Details | Diff

  None (edit)
Description Orion Poplawski 2013-07-25 11:06:09 EDT
Description of problem:

mock uses repoquery to generate a list of available packages for a given chroot.  But repoquery currently cannot make use of the yum cache for the chroot and uses the hosts chroot.  We need to be able to specify the yum cache directory to use, either via --installroot (preferred, because this is how mock calls yum) or a --cachedir option.

Version-Release number of selected component (if applicable):
yum-utils-1.1.31-15.fc19.noarch
Comment 1 Zdeněk Pavlas 2013-07-29 08:41:35 EDT
Created attachment 779867 [details]
repoquery: add --installroot option. BZ 988429
Comment 2 Orion Poplawski 2013-07-29 16:43:48 EDT
Looks good to me, thanks.
Comment 3 Fedora Update System 2013-08-07 09:22:13 EDT
yum-utils-1.1.31-17.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/yum-utils-1.1.31-17.fc19
Comment 4 Fedora Update System 2013-08-07 19:09:59 EDT
Package yum-utils-1.1.31-17.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-utils-1.1.31-17.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14431/yum-utils-1.1.31-17.fc19
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-08-09 13:03:15 EDT
yum-utils-1.1.31-17.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.