Bug 988432 - [RFE] ML2 port binding
Summary: [RFE] ML2 port binding
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron   
(Show other bugs)
Version: 4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M3
: 4.0
Assignee: Bob Kukura
QA Contact: Rami Vaknin
URL: https://blueprints.launchpad.net/neut...
Whiteboard:
Keywords: FutureFeature, OtherQA
Depends On: 894924
Blocks: RHOS40RFE
TreeView+ depends on / blocked
 
Reported: 2013-07-25 15:11 UTC by Bob Kukura
Modified: 2016-04-26 15:45 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-20 00:15:39 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1859 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement Advisory 2013-12-21 00:01:48 UTC

Description Bob Kukura 2013-07-25 15:11:22 UTC
This tracks the upstream Modular L2 plugin portbinding blueprint (https://blueprints.launchpad.net/neutron/+spec/ml2-portbinding).

QE testing of this BP will require making sure the ml2 plugin works with the openvswitch and linuxbridge agents when nova is configured to use the GenericVIFDriver. Security group functionality will need to be tested.

Comment 1 Stephen Gordon 2013-07-26 15:57:07 UTC
Setting docs_scoped- as I think this falls under the more generic "document ML2" bugs I have already cloned to docs.

Comment 11 Rami Vaknin 2013-12-15 14:36:48 UTC
Verified on rhos 4.0 running on rhel 6.5, 2013-12-12.1 puddle, openstack-neutron-2013.2-15.el6ost, openstack-neutron-ml2-2013.2-15.el6ost.

Ports are now get an vif_type (floating ip ports remain with "unbound").

mysql> select * from ml2_port_bindings;
+--------------------------------------+-------------------------------+----------+-----------------+-------------+--------------------------------------+
| port_id                              | host                          | vif_type | cap_port_filter | driver      | segment                              |
+--------------------------------------+-------------------------------+----------+-----------------+-------------+--------------------------------------+
| 05093809-e0c1-4cb9-8f03-0050561984f8 | puma07.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 6f396aa3-b633-4774-97f3-51c6dfd9debe |
| 167815e5-6bf4-4a2c-a712-1806ec894c68 | puma10.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 84a51bbf-e8d6-4439-8361-01a61f20862c |
| 19f70780-02c8-49e6-a023-e001bee00433 | puma07.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | c2ebbde0-95f2-4341-96ae-37cf738bcb40 |
| 2d96e7a0-0362-4530-b755-b1ea47dbc07f |                               | unbound  |               0 | NULL        | NULL                                 |
| 31e16eb2-5ff3-4184-a015-85ba1688d220 | puma10.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 6f396aa3-b633-4774-97f3-51c6dfd9debe |
| 42ba4e9d-4764-4e90-a7bd-e22cff858539 | puma08.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 6f396aa3-b633-4774-97f3-51c6dfd9debe |
| 4b7a00fb-1178-462e-a96d-a6b980215f30 |                               | unbound  |               0 | NULL        | NULL                                 |
| 4d085afc-5eb7-489b-aad2-ee326b27b025 | puma07.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | bafd7780-3aa5-4317-b931-37b3248b3375 |
| 4e0e7cd5-f703-4ee6-8960-bac5a69d4ab4 | puma10.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 6f396aa3-b633-4774-97f3-51c6dfd9debe |
| 5500b6b4-0afb-4905-9b36-4436990f6f8d |                               | unbound  |               0 | NULL        | NULL                                 |
| 5879cc9d-931e-4c65-b035-4d9c6d0ac1ee | puma08.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | bafd7780-3aa5-4317-b931-37b3248b3375 |
| 5e4842b6-5309-4d6b-a742-f9039ba969e4 | puma09.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | c2ebbde0-95f2-4341-96ae-37cf738bcb40 |
| 7c1cb86a-abf3-4565-9984-616308ee4462 | puma10.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 02a074a4-d53c-44e1-9167-634e537c123a |
| 829b4215-2733-443e-a98f-3c509147efb7 |                               | unbound  |               0 | NULL        | NULL                                 |
| 94f8430d-8cde-49fd-8453-b52055ccbaa9 | puma08.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 02a074a4-d53c-44e1-9167-634e537c123a |
| 95966cf7-e3ca-4595-94eb-882ee5a2037a |                               | unbound  |               0 | NULL        | NULL                                 |
| a0f6fd12-f351-4c98-a254-5674d5df1a49 | puma10.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | bafd7780-3aa5-4317-b931-37b3248b3375 |
| a1c8cb62-20ae-4141-9074-ec486a66ef8d | puma10.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | c2ebbde0-95f2-4341-96ae-37cf738bcb40 |
| a2ca1bea-3158-4b20-9336-4b5df20bc41e | puma09.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 6f396aa3-b633-4774-97f3-51c6dfd9debe |
| b2071329-073a-4a18-b1c8-4656ea4153d8 |                               | unbound  |               0 | NULL        | NULL                                 |
| b4edd898-957e-4145-a6ba-25b9f5607a90 | puma08.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | c2ebbde0-95f2-4341-96ae-37cf738bcb40 |
| b8b69cc9-43cd-48e8-804f-1551364bc314 | puma07.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 02a074a4-d53c-44e1-9167-634e537c123a |
| c42a1212-c22a-466e-a782-a554aa395791 |                               | unbound  |               0 | NULL        | NULL                                 |
| cbbc8d79-d028-464c-954f-7d4a3ef056bf | puma09.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | bafd7780-3aa5-4317-b931-37b3248b3375 |
| d6df1a12-23f0-4a6d-8611-001c36fa18d9 |                               | unbound  |               0 | NULL        | NULL                                 |
| daf181ee-2fb3-488e-927b-4895f90457a2 | puma09.scl.lab.tlv.redhat.com | ovs      |               1 | openvswitch | 02a074a4-d53c-44e1-9167-634e537c123a |
| e968dbfa-f531-4935-88b9-d77f644b0dc0 |                               | unbound  |               0 | NULL        | NULL                                 |
+--------------------------------------+-------------------------------+----------+-----------------+-------------+--------------------------------------+
27 rows in set (0.00 sec)

Comment 13 errata-xmlrpc 2013-12-20 00:15:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html


Note You need to log in before you can comment on or make changes to this bug.