Bug 988478 - Can't mco ping new nodes after upgrade - Change mcollective conf from "stomp" to "activemq"
Can't mco ping new nodes after upgrade - Change mcollective conf from "stomp"...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Upgrade (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: John W. Lamb
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 12:33 EDT by Luke Meyer
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version: openshift-enterprise-upgrade-broker-1.2.2-1 openshift-enterprise-upgrade-node-1.2.2-1
Doc Type: Bug Fix
Doc Text:
When upgrading from OpenShift Enterprise 1.1 to 1.2 the Mcollective connector was not migrated to the new ActiveMQ connector. Instead, it still used the deprecated Stomp connector causing some nodes to not respond to 'mco ping' requests. Users are advised to verify that the connector is set to ActiveMQ in the /etc/openshift/{client,server}.cfg files on all nodes and brokers. New upgrades will be migrated to the updated configuration automatically.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 11:29:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Meyer 2013-07-25 12:33:25 EDT
Description of problem:
Our upgrade scripts do not currently make the change in mcollective connector. This is not a problem until one of two things happens:
1. A new node is created with the new instructions which specify "activemq". This will be incompatible with the existing systems - the new nodes will not even respond to mco ping.
2. We upgrade to the next version of mcollective where "stomp" is not just deprecated removed.

Steps to Reproduce:
1. Upgrade OSE 1.1 to OSE 1.2
2. Look in /etc/mcollective/server.cfg on nodes
3. Look in /etc/mcollective/client.cfg on brokers 

Actual results:

connector = stomp
plugin.stomp.pool.size = 1
plugin.stomp.pool.host1 = activemq.ose.example.com
plugin.stomp.pool.port1 = 61613
[...]

Expected results:

connector = activemq
plugin.activemq.pool.size = 1
plugin.activemq.pool.1.host = activemq.ose.example.com
plugin.activemq.pool.1.port = 61613
[...]
(Note the slight difference in format!)

Additional info:
Would be wise to add a check for the old connector in oo-diagnostics and have it refer to a helpful kbase article or at least this bug.
Comment 2 John W. Lamb 2013-09-09 17:28:19 EDT
Fix submitted here: https://github.com/openshift/enterprise/pull/30

Awaiting review
Comment 3 John W. Lamb 2013-09-10 11:55:10 EDT
Merged PR, tested against working single-server and server-pool mcollective configs.
Comment 5 Johnny Liu 2013-09-11 07:42:33 EDT
Verified this bug with the following packages, and PASS.

openshift-enterprise-upgrade-broker-1.2.2-1.el6op.noarch
openshift-enterprise-upgrade-node-1.2.2-1.el6op.noarch

Before upgrade:
# cat ~/client.cfg 
<--snip-->
connector = stomp
plugin.stomp.host = activemq.rhn.com
plugin.stomp.port = 61613
plugin.stomp.user = mcollective
plugin.stomp.password = marionette


# cat ~/server.cfg 
<--snip-->
connector = stomp
plugin.stomp.host = activemq.rhn.com
plugin.stomp.port = 61613
plugin.stomp.user = mcollective
plugin.stomp.password = marionette

After upgrade:
# cat /etc/mcollective/client.cfg
<--snip-->
connector = activemq
plugin.activemq.pool.size = 1
plugin.activemq.pool.1.host = activemq.rhn.com
plugin.activemq.pool.1.port = 61613
plugin.activemq.pool.1.user = mcollective
plugin.activemq.pool.1.password = marionette


# cat /etc/mcollective/server.cfg
<--snip-->
connector = activemq
plugin.activemq.pool.size = 1
plugin.activemq.pool.1.host = activemq.rhn.com
plugin.activemq.pool.1.port = 61613
plugin.activemq.pool.1.user = mcollective
plugin.activemq.pool.1.password = marionette


After upgrade, add a new node with the new instructions which specify "activemq"
mco ping could find this new node.
Comment 8 errata-xmlrpc 2013-09-25 11:29:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1275.html

Note You need to log in before you can comment on or make changes to this bug.