Bug 988484 - cim and snmp plugin pages are missing from tui
cim and snmp plugin pages are missing from tui
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 12:53 EDT by Mike Burns
Modified: 2014-01-21 14:46 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
cim and snmp plugins are installed by default during the image generation, but the screens were not showing on the TUI. Previously, the Python files were defined as _SCRIPT in automake. This has been changed to _PYTHON so they automatically get compiled, and the compiled files added to the RPMs so image-minimizer will leave working plugins. The screens now display in the TUI.
Story Points: ---
Clone Of:
: 1021559 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:46:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Burns 2013-07-25 12:53:37 EDT
Description of problem:
cim and snmp plugins are installed by default during the image generation, but the screens are not showing on the TUI

Version-Release number of selected component (if applicable):
3.0.0-6.1.el6

How reproducible:
always

Steps to Reproduce:
1.boot latest jenkins or initial rhev-h build
2.install and log into the setup ui
3.

Actual results:
no cim or snmp shown

Expected results:
cim and snmp pages are shown

Additional info:
Comment 4 Fabian Deutsch 2013-08-07 06:32:53 EDT
Could it be that the TUI related files *._page.py are missing in the plugin rpms?
Comment 5 Ryan Barry 2013-08-07 10:18:30 EDT
We were getting killed in the minimizer. I have an upstream patch to resolve: http://gerrit.ovirt.org/#/c/17431/
Comment 8 haiyang,dong 2013-10-17 23:11:02 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

cim and snmp plugin pages are still missing from tui. So need to re-assigned this bug again.
Comment 17 Cheryn Tan 2013-11-07 19:38:26 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 18 cshao 2013-11-07 22:23:19 EST
Test version:
rhevh-6.5-20131031.1.0
ovirt-node-3.0.1-7.el6.noarch

Test result:
cim and snmp pages are shown in TUI.
Both cim and snmp can work fine.

So the bug is fixed, change bug status to VERIFIED.
Comment 20 errata-xmlrpc 2014-01-21 14:46:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.