Bug 9885 - undefined symbol: fdio
undefined symbol: fdio
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-01 06:07 EST by frankie
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-20 09:49:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description frankie 2000-03-01 06:07:34 EST
I just upgraded to latest gnorpm-0.9-14
When launched it complains this way :
gnorpm: error in loading shared libraries: gnorpm: undefined symbol: fdio
Comment 1 Nalin Dahyabhai 2000-03-01 14:24:59 EST
Upgrade to the latest version of rpm.  Version 3.0.4-0.42 seems to work here.
Comment 2 frankie 2000-03-02 02:37:59 EST
I upgraded to rpm-3.0.4-0.45 and now gnorpm launches, but when I press
the `Install' button it crashes with that message :

gnorpm: error in loading shared libraries: gnorpm: undefined symbol: fdOpen
Comment 3 Jeff Johnson 2000-03-20 09:49:59 EST
I just checked with
	gnorpm-0.9-15	(from Raw Hide and Red Hat 6.2)
	rpm-3.0.4-6x	(from ftp.rpm.org)
and cannot reproduce the problem.

Both of the symbols fdOpen and fdio are in /usr/lib/librpm.so.0.0.0. You
can verify this by doing, for example,
	nm /usr/lib/librpm.so.0.0.0 | grep fdOpen
If you find the symbol there, then you should try running
	/sbin/ldconfig
and/or check your LD_LIBRARY_PATH or /etc/ld.so.conf configuration.

Note You need to log in before you can comment on or make changes to this bug.