This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988516 - DOCX import: header/footer paragraph properties applied to body paragraph
DOCX import: header/footer paragraph properties applied to body paragraph
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michael Stahl
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 14:26 EDT by Sammy
Modified: 2014-03-15 11:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: libreoffice-4.2.2.1-6.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-15 11:25:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A docx document we had to deal with on Fedora (54.47 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-07-25 14:26 EDT, Sammy
no flags Details

  None (edit)
Description Sammy 2013-07-25 14:26:21 EDT
Created attachment 778445 [details]
A docx document we had to deal with on Fedora

The attached document miserably fails to convert using libreoffice on Fedora 19 (4.1.0.3).
It opens perfectly with the commercial SoftMaker suite on Linux. Tables and mixed
portrait/landscape pages seem to be the culprit.

I know this is not a Fedora issue but it would be nice if this sample file is passed along to
the developers to make them aware of the problems.
Thanks
Comment 1 Caolan McNamara 2013-07-26 06:24:17 EDT
caolanm->mstahl: have a look/get it to the right upstream dev.
Comment 2 Michael Stahl 2014-03-10 08:36:32 EDT
there's spurious numbering (including 7.96 cm indent), starting on the first landscape page... and also inside the tables which appear empty because the cells are less wide than the indent.

problem is that the numbering from the footer is erroneously
applied to the paragraph in the body.  this has always been the case,
but in 4.1 it got worse because the numbering is applied to more than
just 1 body paragraph.

fixed in upstream master commit:
2b78f2cd7b9e4bab0f3b3b9119238f36a1bbc7b2

fixed in upstream libreoffice-4-2 for 4.2.3.1:
9a156365277c93bd66c2ef21c42bfa377eaf314b

fixed in upstream libreoffice-4-1 for 4.1.6.1:
155397041b1a5687259605de1e33ed86ed955821

added patch to Fedora 20 and 19 branches.
Comment 3 Fedora Update System 2014-03-11 06:46:20 EDT
libreoffice-4.2.2.1-6.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libreoffice-4.2.2.1-6.fc20
Comment 4 Fedora Update System 2014-03-12 08:25:02 EDT
Package libreoffice-4.2.2.1-6.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-4.2.2.1-6.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3760/libreoffice-4.2.2.1-6.fc20
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2014-03-15 11:25:32 EDT
libreoffice-4.2.2.1-6.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.