Bug 988522 - Our v1 Wiki docs are confusing v2 users
Our v1 Wiki docs are confusing v2 users
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: documentation (Show other bugs)
Master
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Randy Barlow
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 14:42 EDT by Randy Barlow
Modified: 2014-10-21 14:43 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-21 14:43:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Randy Barlow 2013-07-25 14:42:43 EDT
We occasionally have users who get confused by the documentation in our wiki (which is for v1) complaining that our pulp CLI does not work.

We should either eliminate that documentation (if we no longer need to document v1), or add red boxes all over it that say that it's for the old unsupported version, and they should see the new documentation (with a link).
Comment 1 Sayli Karmarkar 2013-09-20 00:36:05 EDT
Moving to NEW as it is not being worked on right now.
Comment 2 Barnaby Court 2013-11-04 08:49:51 EST
Move back to pulp-bugs as it is low priority.  A fair amount of work has been completed.  When it gets picked up go back through the docs to figure out what additional needs to be done.
Comment 3 Randy Barlow 2014-10-02 16:29:32 EDT
I wasn't able to find this fedorahosted.org in Bugzilla's "External Bug Tracker" feature, but I filed this ticket with them:

https://fedorahosted.org/fedora-infrastructure/ticket/4553

I'm marking this as needsinfo until we hear back from them.
Comment 4 Randy Barlow 2014-10-03 09:48:23 EDT
Fedorahosted opted to put our Wiki into a deny rule in robots.txt, so search engines should not find our wiki anymore in the near future.

https://fedorahosted.org/robots.txt
Comment 5 Preethi Thomas 2014-10-15 08:46:31 EDT
verified
Comment 6 Randy Barlow 2014-10-21 11:26:47 EDT
I've reopened the fedorahosted bug about this:

https://fedorahosted.org/fedora-infrastructure/ticket/4553#comment:2
Comment 7 Brian Bouterse 2014-10-21 11:30:11 EDT
I'm re-opening this bug because we also need to robots.txt the user guide portion of pulpprojects.org/ using a robots.txt. I believe a disallow rule for the following is all that is needed:

/ug/*
Comment 8 Brian Bouterse 2014-10-21 11:42:04 EDT
Medium priority seems more appropriate, but leaving assigned to rbarlow
Comment 9 Randy Barlow 2014-10-21 14:43:43 EDT
fedorahosted is again showing the correct robots.txt.

Since the user guide is a separate website than this ticket is about, I'm going to close this ticket as resolved again. The user guide does very largely say "v1" at the top. We could file a ticket about changing its robots.txt if we wanted to, but the links to it also call it the "legacy" docs.

Note You need to log in before you can comment on or make changes to this bug.