Bug 988635 - [abrt] WARNING: at fs/btrfs/super.c:255 __btrfs_abort_transaction+0xcf/0xf0 [btrfs]()
[abrt] WARNING: at fs/btrfs/super.c:255 __btrfs_abort_transaction+0xcf/0xf0 [...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: fedora-kernel-btrfs
Fedora Extras Quality Assurance
abrt_hash:b490a3318eea25bab2702dd7e80...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 23:06 EDT by Michael Dempsey
Modified: 2013-09-23 16:17 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 16:17:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (189.54 KB, text/plain)
2013-07-25 23:06 EDT, Michael Dempsey
no flags Details

  None (edit)
Description Michael Dempsey 2013-07-25 23:06:29 EDT
Additional info:
reporter:       libreport-2.1.5
WARNING: at fs/btrfs/super.c:255 __btrfs_abort_transaction+0xcf/0xf0 [btrfs]()
Hardware name: 4286CTO
Modules linked in: usb_storage fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables rfcomm bnep snd_hda_codec_hdmi vfat snd_hda_codec_conexant fat snd_hda_intel snd_hda_codec arc4 mperf coretemp kvm_intel kvm crc32_pclmul crc32c_intel ghash_clmulni_intel snd_hwdep snd_seq iwldvm mac80211 snd_seq_device snd_pcm iTCO_wdt uvcvideo videobuf2_vmalloc snd_page_alloc videobuf2_memops videobuf2_core videodev mmc_block iTCO_vendor_support media iwlwifi thinkpad_acpi snd_timer microcode snd e1000e btusb cfg80211 sdhci_pci sdhci bluetooth mmc_core lpc_ich mfd_core soundcore ptp pps_core rfkill i2c_i801 mei wmi uinput binfmt_misc btrfs libcrc32c xor zlib_deflate raid6_pq i915 i2c_algo_bit drm_kms_helper drm i2c_core video
Pid: 19454, comm: umount Not tainted 3.9.9-301.fc19.x86_64 #1
Call Trace:
 [<ffffffffa015ad00>] ? __btrfs_abort_transaction+0x70/0xf0 [btrfs]
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa015ad5f>] __btrfs_abort_transaction+0xcf/0xf0 [btrfs]
 [<ffffffffa0185222>] cleanup_transaction+0x72/0x270 [btrfs]
 [<ffffffffa015ac1e>] ? btrfs_printk+0x8e/0x100 [btrfs]
 [<ffffffff81081050>] ? wake_up_bit+0x30/0x30
 [<ffffffffa0183e1b>] btrfs_commit_transaction+0x36b/0xa80 [btrfs]
 [<ffffffff81081050>] ? wake_up_bit+0x30/0x30
 [<ffffffff81643d52>] ? mutex_lock+0x12/0x30
 [<ffffffffa017e936>] btrfs_commit_super+0x86/0x100 [btrfs]
 [<ffffffffa01800d8>] close_ctree+0x308/0x360 [btrfs]
 [<ffffffff811b39bf>] ? evict_inodes+0xbf/0x110
 [<ffffffffa0156359>] btrfs_put_super+0x19/0x20 [btrfs]
 [<ffffffff8119ba86>] generic_shutdown_super+0x56/0xd0
 [<ffffffff8119bca2>] kill_anon_super+0x12/0x20
 [<ffffffffa015a106>] btrfs_kill_super+0x16/0x90 [btrfs]
 [<ffffffff8119c083>] deactivate_locked_super+0x33/0x80
 [<ffffffff8119c116>] deactivate_super+0x46/0x60
 [<ffffffff811b7265>] mntput_no_expire+0xc5/0x120
 [<ffffffff811b80f1>] sys_umount+0x91/0x3d0
 [<ffffffff810dcb36>] ? __audit_syscall_exit+0x1f6/0x2a0
 [<ffffffff8164f319>] system_call_fastpath+0x16/0x1b

Potential duplicate: bug 967956
Comment 1 Michael Dempsey 2013-07-25 23:06:34 EDT
Created attachment 778638 [details]
File: dmesg
Comment 2 Josh Boyer 2013-09-18 16:50:03 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 3 Josef Bacik 2013-09-23 16:17:27 EDT
Transaction aborts are usually do to something going wrong on the fs.  Please reproduce on btrfs-next (or at the very least a recent kernel) and if you are still having issues please file a bugzilla at bugzilla.kernel.org and set the component to btrfs.

Note You need to log in before you can comment on or make changes to this bug.