Bug 988642 - quota: hitting "D" state for dd command
quota: hitting "D" state for dd command
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: write-behind (Show other bugs)
mainline
x86_64 All
unspecified Severity high
: ---
: ---
Assigned To: Raghavendra G
:
Depends On: 982629
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-25 23:44 EDT by Raghavendra G
Modified: 2014-04-17 07:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 982629
Environment:
Last Closed: 2014-04-17 07:44:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-07-25 23:45:57 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing more accurately.) posted (#1) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 2 Anand Avati 2013-07-29 02:58:23 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#2) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 3 Anand Avati 2013-07-29 02:59:53 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#3) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 4 Anand Avati 2013-07-29 14:19:32 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#4) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 5 Anand Avati 2013-07-29 14:20:41 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#5) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 6 Anand Avati 2013-08-06 00:05:13 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#6) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 7 Anand Avati 2013-08-06 23:28:03 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#7) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 8 Anand Avati 2013-08-06 23:28:51 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#8) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 9 Anand Avati 2013-08-06 23:29:20 EDT
REVIEW: http://review.gluster.org/5398 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#9) for review on master by Raghavendra G (rgowdapp@redhat.com)
Comment 10 Anand Avati 2013-08-14 05:12:38 EDT
COMMIT: http://review.gluster.org/5398 committed in master by Anand Avati (avati@redhat.com) 
------
commit 1e49b3ac9b1019c742236be8db0ca8ec00750ae7
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Mon Jul 29 23:43:51 2013 +0530

    performance/write-behind: invoke request queue processing if
    we find fd marked bad while trying to fulfill lies.
    
    * flush was queued behind some unfulfilled write.
    * A previously wound write returned an error and hence fd was marked
      bad with corresponding error.
    * wb_fulfill_head (invocation probably rooted in wb_flush), before
      winding checks for failures of previous writes and since there was a
      failure, calls wb_head_done without even winding one request in head.
    * wb_head_done unrefs all the requests in list "head".
    * since flush was last operation on fd (and most likely last operation
      on inode itself), no one invokes wb_process_queue and flush is stuck
      in request queue for eternity.
    
    Change-Id: I3b5b114a1c401d477dd7ff64fb6119b43fda2d18
    BUG: 988642
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/5398
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 11 Anand Avati 2013-09-09 20:56:09 EDT
REVIEW: http://review.gluster.org/5883 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 12 Anand Avati 2013-09-09 21:08:36 EDT
REVIEW: http://review.gluster.org/5883 (performance/write-behind: invoke request queue processing if we find fd marked bad while trying to fulfill lies.) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 13 Anand Avati 2013-09-10 04:25:26 EDT
COMMIT: http://review.gluster.org/5883 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 8641a8641c4efec9cc7ac20108f2461a0300d01c
Author: Raghavendra G <rgowdapp@redhat.com>
Date:   Mon Jul 29 23:43:51 2013 +0530

    performance/write-behind: invoke request queue processing if
    we find fd marked bad while trying to fulfill lies.
    
    * flush was queued behind some unfulfilled write.
    * A previously wound write returned an error and hence fd was marked
      bad with corresponding error.
    * wb_fulfill_head (invocation probably rooted in wb_flush), before
      winding checks for failures of previous writes and since there was a
      failure, calls wb_head_done without even winding one request in head.
    * wb_head_done unrefs all the requests in list "head".
    * since flush was last operation on fd (and most likely last operation
      on inode itself), no one invokes wb_process_queue and flush is stuck
      in request queue for eternity.
    
    Change-Id: I3b5b114a1c401d477dd7ff64fb6119b43fda2d18
    BUG: 988642
    Signed-off-by: Raghavendra G <rgowdapp@redhat.com>
    Reviewed-on: http://review.gluster.org/5883
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 14 Niels de Vos 2014-04-17 07:44:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.