Bug 988660 - libvirt handle leak
libvirt handle leak
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
x86_64 Windows
unspecified Severity high
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 01:39 EDT by shichangyou
Modified: 2013-07-29 05:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 05:24:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shichangyou 2013-07-26 01:39:09 EDT
Description of problem:

 the libvirt in windows will result in handle leak

Version-Release number of selected component (if applicable):

libvirt client version0.8.8 in win7
libvirtd using libvirt 0.8.5 in rhve 5.5

How reproducible:
 

Steps to Reproduce:
1. in win7 start the virsh.exe tool
2.  excute the list or dominfo command of virsh tool
3.  the handle of the process virsh.exe increase limitless

 i try to debug this bug, i find every call of prepareCall function in libvirt lib, it generate some mutex handle , but the libvirt do not destroy the unused mutex handle. 

 in prepareCall  it call virCondInit to new a mutex,  but it not call virCondDestroy, so the handle leak.   
  why??

Actual results:


Expected results:


Additional info:
Comment 1 Peter Krempa 2013-07-29 05:24:59 EDT
The libvirt version 0.8.8 is really old and since it was released we've done a couple releases that fixed quite a lot resource leaks. Please re-test if this issue still happens with the current upstream version. If it does happen please attach information about the leak from the debugging tool and also libvirt logs.

I'm closing this as fixed UPSTREAM. If it isn't fixed in the current upstream version, please re-open this bug.

Note You need to log in before you can comment on or make changes to this bug.