This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988666 - An error occurred while configuring puppet in transaction puppet page
An error occurred while configuring puppet in transaction puppet page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ryan Barry
Virtualization Bugs
:
Depends On: 986789
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 02:07 EDT by haiyang,dong
Modified: 2014-01-21 14:46 EST (History)
15 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-2.el6
Doc Type: Bug Fix
Doc Text:
When using edit-node install ovirt-node-plugin-puppet into ovirt-node-iso, entering into the puppet page and enabling the puppet service, then configuring the puppet server and puppet certificate name, clicking "save & Run", an error occurred while configuring puppet in the transaction puppet page: "An error occurred while applying the changes: __init__() takes exactly 2 arguments(3 given)" This was occurring because ovirt.node.utils.fs.File() has changed arguments, this mode is no longer set, but the puppet_page was doing so. It has been changed to the new interface, and now works correctly.
Story Points: ---
Clone Of: 986789
Environment:
Last Closed: 2014-01-21 14:46:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2013-07-26 02:07:33 EDT
+++ This bug was initially created as a clone of Bug #986789 +++

Description of problem:
Using edit-node install ovirt-node-plugin-puppet into ovirt-node-iso,
enter into puppet page and enabled puppet service and configure the puppet server
and puppet certificate name
then clicking "save & Run" button. but An error occurred while configuring puppet 
in transaction puppet page with the follow error info:
An error occurred while applying the changes:
__init__() takes exactly 2 arguments(3 given) (Seen puppet transaction page.png)


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-3.999.999.20130716190656git4e57356.2850.fc18.src.rpm
ovirt-node-plugin-puppet-3.1.0-0.999.20130722032114git68f34db.fc18.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

   

Actual results:


Expected results:


Additional info:
Comment 1 haiyang,dong 2013-07-26 02:11:29 EDT
Could reproduce this issue on the follow build:
ovirt-node-plugin-puppet-3.0.0-6.1.el6.noarch.rpm
ovirt-node-tools-3.0.0-6.1.el6.noarch.rpm 
rhev-hypervisor6-6.5-20130725.0.el6

so need to clone it from ovirt-node upstream to downstream to track this issue
Comment 7 Cheryn Tan 2013-11-07 19:25:29 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 haiyang,dong 2013-12-16 03:10:31 EST
Test version:
ovirt-node-3.0.1-9.el6_5.noarch.rpm
rhevh-6.5-20131213.0.0.iso
ovirt-node-plugin-puppet-3.0.1-9.el6_5.noarch.rpm

Test as follow:
Using edit-node install ovirt-node-plugin-puppet into rhevh-6.5-20131213.0.0.iso and clean install this
iso .Login it and enter into puppet page, configure 
Puppet Server:dhcp-10-214.nay.redhat.com
Puppet Certificate Name: dhcp-10-106.nay.redhat.com

after clicking "Save" button to apply this configuration. check that no error info:
"An error occurred while applying the changes:
__init__() takes exactly 2 arguments(3 given)"
occurred while configuring puppet 
in transaction puppet page

so this bug has been fixed,change the status into "verified".
Comment 9 haiyang,dong 2014-01-16 05:14:11 EST
Also this bug was fixed in the follow version:
rhevh-6.5-20140110.1
ovirt-node-3.0.1-16.el6_5.noarch
ovirt-node-plugin-puppet-3.0.1-16.el6_5.noarch.rpm
Comment 11 errata-xmlrpc 2014-01-21 14:46:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.