Bug 988705 - [abrt] kdelibs-4.10.5-1.fc19: KScreen::Mode::size: Process /usr/bin/kded4 was killed by signal 11 (SIGSEGV)
[abrt] kdelibs-4.10.5-1.fc19: KScreen::Mode::size: Process /usr/bin/kded4 was...
Status: CLOSED DUPLICATE of bug 981624
Product: Fedora
Classification: Fedora
Component: kdelibs (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
abrt_hash:2de04da3429e9c0608c89b3630f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 03:47 EDT by Vincenzo Pupillo
Modified: 2013-07-26 04:55 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 04:55:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (75.01 KB, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: cgroup (142 bytes, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: core_backtrace (7.74 KB, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: dso_list (24.29 KB, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: environ (2.03 KB, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: limits (1.29 KB, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: maps (111.54 KB, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: open_fds (1.40 KB, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: proc_pid_status (950 bytes, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: var_log_messages (316 bytes, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details
File: xsession_errors (96 bytes, text/plain)
2013-07-26 03:47 EDT, Vincenzo Pupillo
no flags Details

  None (edit)
Description Vincenzo Pupillo 2013-07-26 03:47:06 EDT
Description of problem:
Update, via yum, of some library and the restart of the xserver, the  crash occurs after login using kdm. 

 Aggiornato NetworkManager-vpnc-1:0.9.3.997-4.fc19.x86_64        @?fedora
    Update                         1:0.9.8.2-1.fc19.x86_64          @updates
    Aggiornato device-mapper-persistent-data-0.1.4-3.fc19.x86_64    @?fedora
    Update                                   0.2.1-1.fc19.x86_64    @updates
    Aggiornato evolution-data-server-3.8.3-3.fc19.x86_64            @updates
    Update                           3.8.4-1.fc19.x86_64            @updates
    Aggiornato glusterfs-3.4.0-0.9.beta4.fc19.x86_64                @updates
    Update               3.4.0-2.fc19.x86_64                        @updates
    Aggiornato glusterfs-api-3.4.0-0.9.beta4.fc19.x86_64            @updates
    Update                   3.4.0-2.fc19.x86_64                    @updates
    Aggiornato glusterfs-fuse-3.4.0-0.9.beta4.fc19.x86_64           @updates
    Update                    3.4.0-2.fc19.x86_64                   @updates
    Aggiornato gpm-libs-1.20.6-31.fc19.x86_64                       @?fedora
    Update              1.20.6-33.fc19.x86_64                       @updates
    Aggiornato gtkhtml3-4.6.5-1.fc19.x86_64                         @?fedora
    Update              4.6.6-1.fc19.x86_64                         @updates
    Aggiornato harfbuzz-0.9.18-3.fc19.i686                          @?fedora
    Aggiornato harfbuzz-0.9.18-3.fc19.x86_64                        @?fedora
    Update              0.9.19-1.fc19.i686                          @updates
    Update              0.9.19-1.fc19.x86_64                        @updates
    Aggiornato harfbuzz-devel-0.9.18-3.fc19.x86_64                  @?fedora
    Update                    0.9.19-1.fc19.x86_64                  @updates
    Aggiornato harfbuzz-icu-0.9.18-3.fc19.x86_64                    @?fedora
    Update                  0.9.19-1.fc19.x86_64                    @updates
    Aggiornato intel-gpu-tools-2.21.8-1.fc19.x86_64                 @?fedora
    Update                     2.21.12-1.fc19.x86_64                @updates
    Aggiornato libksane-4.10.5-1.fc19.x86_64                        @updates
    Update              4.10.5-3.fc19.x86_64                        @updates
    Aggiornato libssh-0.5.4-3.fc19.x86_64                           @?fedora
    Update            0.5.4-4.fc19.x86_64                           @updates
    Aggiornato powertop-2.3-4.fc19.x86_64                           @updates
    Update              2.4-1.fc19.x86_64                           @updates
    Aggiornato python-pip-1.3.1-3.fc18.noarch                       @updates/18
    Update                1.3.1-4.fc19.noarch                       @updates
    Aggiornato python3-pip-1.3.1-3.fc18.noarch                      @updates/18
    Update                 1.3.1-4.fc19.noarch                      @updates
    Aggiornato qt-creator-2.7.0-1.fc19.x86_64                       @?fedora
    Update                2.8.0-1.fc19.x86_64                       @updates
    Aggiornato qtwebkit-2.3.1-1.fc19.i686                           @?fedora
    Aggiornato qtwebkit-2.3.1-1.fc19.x86_64                         @?fedora
    Update              2.3.2-1.fc19.i686                           @updates
    Update              2.3.2-1.fc19.x86_64                         @updates
    Aggiornato qtwebkit-devel-2.3.1-1.fc19.x86_64                   @?fedora
    Update                    2.3.2-1.fc19.x86_64                   @updates
    Aggiornato shared-desktop-ontologies-0.10.0-4.fc19.noarch       @?fedora
    Update                               0.11.0-1.fc19.noarch       @updates
    Aggiornato shared-desktop-ontologies-devel-0.10.0-4.fc19.noarch @?fedora
    Update                                     0.11.0-1.fc19.noarch @updates
    Aggiornato soprano-2.9.2-1.fc19.x86_64                          @?fedora
    Update             2.9.3-1.fc19.x86_64                          @updates
    Aggiornato soprano-devel-2.9.2-1.fc19.x86_64                    @?fedora
    Update                   2.9.3-1.fc19.x86_64                    @updates
    Aggiornato xorg-x11-drv-intel-2.21.8-1.fc19.x86_64              @?fedora
    Update                        2.21.12-1.fc19.x86_64             @updates
    Aggiornato xorg-x11-drv-synaptics-1.7.1-3.fc19.x86_64           @updates
    Update                            1.7.1-4.fc19.x86_64           @updates
    Aggiornato xorg-x11-server-Xephyr-1.14.2-5.fc19.x86_64          @updates
    Update                            1.14.2-7.fc19.x86_64          @updates
    Aggiornato xorg-x11-server-Xorg-1.14.2-5.fc19.x86_64            @updates
    Update                          1.14.2-7.fc19.x86_64            @updates
    Aggiornato xorg-x11-server-common-1.14.2-5.fc19.x86_64          @updates
    Update                            1.14.2-7.fc19.x86_64          @updates
    Aggiornato xscreensaver-base-1:5.21-10.fc19.x86_64              @updates
    Update                       1:5.22-1.fc19.x86_64               @updates
    Aggiornato xscreensaver-extras-1:5.21-10.fc19.x86_64            @updates
    Update                         1:5.22-1.fc19.x86_64             @updates
    Aggiornato xscreensaver-extras-base-1:5.21-10.fc19.x86_64       @updates
    Update                              1:5.22-1.fc19.x86_64        @updates
    Aggiornato xscreensaver-gl-base-1:5.21-10.fc19.x86_64           @updates
    Update                          1:5.22-1.fc19.x86_64            @updates
    Aggiornato xscreensaver-gl-extras-1:5.21-10.fc19.x86_64         @updates
    Update                            1:5.22-1.fc19.x86_64          @updates

Version-Release number of selected component:
kdelibs-4.10.5-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/bin/kded4 --nocrashhandler
crash_function: KScreen::Mode::size
executable:     /usr/bin/kded4
kernel:         3.9.9-302.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 KScreen::Mode::size at /usr/src/debug/libkscreen-1.0/src/mode.cpp:83
 #1 XRandRConfig::applyKScreenConfig at /usr/src/debug/libkscreen-1.0/backends/xrandr/xrandrconfig.cpp:164
 #2 KScreen::Config::setConfig at /usr/src/debug/libkscreen-1.0/src/config.cpp:66
 #3 KScreenDaemon::applyKnownConfig at /usr/src/debug/kscreen-1.0/kded/daemon.cpp:110
 #4 KScreenDaemon::applyConfig at /usr/src/debug/kscreen-1.0/kded/daemon.cpp:94
 #5 QMetaObject::activate at kernel/qobject.cpp:3539
 #7 Device::ready at /usr/src/debug/kscreen-1.0/x86_64-redhat-linux-gnu/kded/moc_device.cpp:112
 #8 setReady at /usr/src/debug/kscreen-1.0/kded/device.cpp:80
 #9 Device::isLaptopFetched at /usr/src/debug/kscreen-1.0/kded/device.cpp:122
 #10 QMetaObject::activate at kernel/qobject.cpp:3539
Comment 1 Vincenzo Pupillo 2013-07-26 03:47:13 EDT
Created attachment 778693 [details]
File: backtrace
Comment 2 Vincenzo Pupillo 2013-07-26 03:47:18 EDT
Created attachment 778694 [details]
File: cgroup
Comment 3 Vincenzo Pupillo 2013-07-26 03:47:22 EDT
Created attachment 778695 [details]
File: core_backtrace
Comment 4 Vincenzo Pupillo 2013-07-26 03:47:27 EDT
Created attachment 778696 [details]
File: dso_list
Comment 5 Vincenzo Pupillo 2013-07-26 03:47:31 EDT
Created attachment 778697 [details]
File: environ
Comment 6 Vincenzo Pupillo 2013-07-26 03:47:35 EDT
Created attachment 778698 [details]
File: limits
Comment 7 Vincenzo Pupillo 2013-07-26 03:47:39 EDT
Created attachment 778699 [details]
File: maps
Comment 8 Vincenzo Pupillo 2013-07-26 03:47:44 EDT
Created attachment 778700 [details]
File: open_fds
Comment 9 Vincenzo Pupillo 2013-07-26 03:47:49 EDT
Created attachment 778701 [details]
File: proc_pid_status
Comment 10 Vincenzo Pupillo 2013-07-26 03:47:53 EDT
Created attachment 778702 [details]
File: var_log_messages
Comment 11 Vincenzo Pupillo 2013-07-26 03:47:57 EDT
Created attachment 778703 [details]
File: xsession_errors
Comment 12 Daniel Vrátil 2013-07-26 04:55:36 EDT

*** This bug has been marked as a duplicate of bug 981624 ***

Note You need to log in before you can comment on or make changes to this bug.