Bug 98871 - Can't view any type details in the 'Content Types' tab
Can't view any type details in the 'Content Types' tab
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rafael H. Schloming
Jon Orris
:
Depends On:
Blocks: rc0blockers
  Show dependency treegraph
 
Reported: 2003-07-09 14:09 EDT by Daniel Berrange
Modified: 2014-12-01 18:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-15 17:14:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Berrange 2003-07-09 14:09:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
When selecting an individual type in the 'Content Types' tab, you get an error:

com.arsdigita.domain.DataObjectNotFoundException: No matching content type for
object type com.arsdigita.cms.Article
        at
com.arsdigita.cms.ContentType.findByAssociatedObjectType(ContentType.java:338)
        at
com.arsdigita.cms.ui.type.ContentTypePropertyList.getParent(ContentTypePropertyList.java:95)
        at
com.arsdigita.cms.ui.type.ContentTypePropertyList.properties(ContentTypePropertyList.java:72)
        at com.arsdigita.toolbox.ui.PropertyList.generateXML(PropertyList.java:62)
        at com.arsdigita.toolbox.ui.ActionGroup.generateXML(ActionGroup.java:78)
        at com.arsdigita.toolbox.ui.Section.generateXML(Section.java:116)
        at com.arsdigita.bebop.SimpleContainer.generateXML(SimpleContainer.java:245)
        at com.arsdigita.toolbox.ui.ModalPanel.generateXML(ModalPanel.java:84)
        at com.arsdigita.toolbox.ui.ModalPanel.generateXML(ModalPanel.java:84)
        at com.arsdigita.toolbox.ui.LayoutPanel.section(LayoutPanel.java:80)
        at com.arsdigita.toolbox.ui.LayoutPanel.generateXML(LayoutPanel.java:65)
        at com.arsdigita.bebop.TabbedPane.generateXML(TabbedPane.java:444)
        at com.arsdigita.bebop.SimpleContainer.generateXML(SimpleContainer.java:245)
        at com.arsdigita.bebop.Page.generateXML(Page.java:638)
        at com.arsdigita.bebop.Page.buildDocument(Page.java:736)
        at com.arsdigita.cms.dispatcher.CMSPage$1.excurse(CMSPage.java:262)
        at com.arsdigita.cms.CMSExcursion.run(CMSExcursion.java:71)
        at com.arsdigita.cms.dispatcher.CMSPage.dispatch(CMSPage.java:270)
        at
com.arsdigita.cms.dispatcher.CMSDispatcher.dispatch(CMSDispatcher.java:257)
        at
com.arsdigita.cms.dispatcher.CMSDispatcher.chainedDispatch(CMSDispatcher.java:337)
        at
com.arsdigita.dispatcher.DispatcherChain.dispatch(DispatcherChain.java:74)
        at
com.arsdigita.cms.ContentSectionServlet.doService(ContentSectionServlet.java:134)
        at
com.arsdigita.web.BaseApplicationServlet$1.excurse(BaseApplicationServlet.java:111)
        at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
        at
com.arsdigita.web.BaseApplicationServlet.doService(BaseApplicationServlet.java:105)
        at com.arsdigita.web.BaseServlet$1.excurse(BaseServlet.java:119)
        at com.arsdigita.kernel.KernelExcursion.run(KernelExcursion.java:57)
        at com.arsdigita.web.BaseServlet.internalService(BaseServlet.java:94)
        at com.arsdigita.web.BaseServlet.doGet(BaseServlet.java:196)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:126)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)


This is because the parent object type of most content types, doesn't have an
associated ContentType object.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to content types tab
2. Select 'Article' content type.

    

Actual Results:  Get unexpected error

Expected Results:  Content type details are displayed.


Additional info:
Comment 1 Justin Ross 2003-07-09 16:48:20 EDT
Ropening.  I still get the above exception when going to, say, an article.
Comment 2 Justin Ross 2003-07-09 16:54:05 EDT
Sorry, I was looking at the wrong server.  It is in fact fixed :).

Note You need to log in before you can comment on or make changes to this bug.