Bug 988713 - gzip "--rsyncable" option is not documented in man page
gzip "--rsyncable" option is not documented in man page
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.6
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1106360
  Show dependency treegraph
 
Reported: 2013-07-26 04:24 EDT by Eduardo Minguez
Modified: 2014-10-14 03:26 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: --rsyncable options was not documented Consequence: incomplete documentation Fix: description of --rsyncable option added Result: updated documentation
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-14 03:26:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
--rsyncable missing in gzip.1 man page (1.23 KB, patch)
2014-06-06 03:30 EDT, Jan Chaloupka
no flags Details | Diff
--rsyncable missing in gzip.1 man page (1.26 KB, patch)
2014-06-06 07:55 EDT, Jan Chaloupka
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1113597 None None None Never
CentOS 4083 None None None Never

  None (edit)
Description Eduardo Minguez 2013-07-26 04:24:15 EDT
Description of problem:
gzip "--rsyncable" option is not documented in the man, but appears in the "-h" included help (and should be in the code itself)

Version-Release number of selected component (if applicable):
gzip-1.3.12-18.el6.x86_64 (but I think it's never included, so it maybe applies to gzip-*)

How reproducible:
Find "rsyncable" in man pages of gzip

Steps to Reproduce:
1. install gzip
2. man gzip
3. search for rsyncable

Actual results:
No "rsyncable" found

Expected results:
rsyncable flag explanation

Additional info:
Comment 2 RHEL Product and Program Management 2013-10-13 19:20:18 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Jan Chaloupka 2014-06-05 03:56:20 EDT
After reading:

http://lists.gnu.org/archive/html/bug-gzip/2010-06/msg00002.html

and

http://beeznest.wordpress.com/2005/02/03/rsyncable-gzip/

this could be the solution:

--rsyncable
	Having a compressed file and synchronized between two computers using rsync, this option allows after changing a file not to sent an entire new archive but just a small portion of it. Normally, after a change in any file of an archive, compressing algorithm can generate completelly diffrent archive that differ from the old one. This causes rsync to transmit entirely new version to the remote computer. With this option, rsync is able to transmit just the changed portions (plus some minimal padding in the area of the archive that necessarily changed as a result of the changes in the file).

After grammar correction of course :)

What do you think, Petr, Eduardo? Is it sufficient explanation?
Comment 4 Eduardo Minguez 2014-06-05 04:03:02 EDT
It's pretty explanatory for me.
Thanks!
Comment 5 pstodulk 2014-06-05 04:22:56 EDT
Yes, this could be the solution.
Comment 6 Jan Chaloupka 2014-06-05 06:00:39 EDT
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=17698
Comment 7 Jan Chaloupka 2014-06-06 03:30:46 EDT
Created attachment 902787 [details]
--rsyncable missing in gzip.1 man page

From upstream, --rsyncable is only RH/Fedora feature.
Comment 8 pstodulk 2014-06-06 04:13:07 EDT
Thank you Jan. I will apply your patch
Comment 11 Jan Chaloupka 2014-06-06 07:55:28 EDT
Created attachment 902891 [details]
--rsyncable missing in gzip.1 man page

Man page text checked and corrected by mariel@redhat.com. Thanks again.

Now it is applicable, Petr.
Comment 19 errata-xmlrpc 2014-10-14 03:26:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1382.html

Note You need to log in before you can comment on or make changes to this bug.