Bug 988723 - Auto upgrade from RHEV Hypervisor 6.4 to 6.5 will be failed because of a minimum required size of ROOT
Auto upgrade from RHEV Hypervisor 6.4 to 6.5 will be failed because of a mini...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 04:53 EDT by Longjun Song
Modified: 2014-01-21 14:47 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:47:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Longjun Song 2013-07-26 04:53:00 EDT
Description of problem:
Auto upgrade from RHEVH Hypervisor 6.4 to 6.5 will be failed, it will say:
OVIRT_VOL_ROOT_SIZE is smaller than minimum required size of : 512
Traceback (most recent call last):
    File "<stdin>", line 2, in <module>
    File "/usr/lib/python2.6/site-packages/ovirtnode/install.py", line 42, int __init__
TypeError: __init__() should return None
Automatic installation failed. Please review console messages.
Press Enter to drop to emergency shell.

Version-Release number of selected component (if applicable):
RHEV Hypervisor 6.5-20130725.0.el6

How reproducible:
100%

Steps to Reproduce:
1. Clean install a RHEV Hypervisor 6.4.
2. Boot from PXE and select RHEV Hypervisor 6.5-20130725.0.el6 with an upgrade argument, then the error will occur.


Actual results:

Expected results:

Additional info:
Add the storage_vol argument to set the size of ROOT partition bigger than 512MB, the problem will be solved.
Comment 3 RHEL Product and Program Management 2013-10-13 23:01:14 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 6 Cheryn Tan 2013-11-07 19:25:12 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 Longjun Song 2013-11-07 23:23:04 EST
Steps:
1. Clean install Redhat Hypervisor 6.4-20131016 and upgrade the OS from PXE with a command 'upgrade' to RHEV Hypervisor 6.5-20131031.1.0
2. This bug will not occur any longer
Comment 11 errata-xmlrpc 2014-01-21 14:47:07 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.