Bug 988747 - [RFE] Beakerlib functions rlAssertExists and rlAssertNotExists should differentiate between file and directory
[RFE] Beakerlib functions rlAssertExists and rlAssertNotExists should differe...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beakerlib (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Muller
Fedora Extras Quality Assurance
:
Depends On:
Blocks: Fedora-beakerlib-1.9-3 1116317
  Show dependency treegraph
 
Reported: 2013-07-26 05:48 EDT by Filip Holec
Modified: 2016-09-19 22:11 EDT (History)
3 users (show)

See Also:
Fixed In Version: beakerlib-1.9-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-30 02:57:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for beakerlib to modify rlAssertExists and rlAssertNotExists output message (2.02 KB, patch)
2013-07-26 05:48 EDT, Filip Holec
no flags Details | Diff
Simple test (712 bytes, application/octetstream)
2013-07-26 05:51 EDT, Filip Holec
no flags Details

  None (edit)
Description Filip Holec 2013-07-26 05:48:43 EDT
Created attachment 778721 [details]
Patch for beakerlib to modify rlAssertExists and rlAssertNotExists output message

Description of problem:
Since functions rlAssertExists and rlAssertNotExists work well with directories, we should modify the output message properly.

Version-Release number of selected component (if applicable):
beakerlib-1.8

How reproducible:
Always

Steps to Reproduce:
1. Create a directory in test
2. Run rlAssertExists with directory path as argument
3. Run rlAssertNotExists with directory path as argument

Actual results:
File $dir should exist
File $dir should not exist

Expected results:
Directory $dir should exist
Directory $dir should not exist

Additional info:
Comment 1 Filip Holec 2013-07-26 05:51:51 EDT
Created attachment 778722 [details]
Simple test

Added simple beakerlib test
Comment 2 Petr Muller 2013-08-12 08:34:45 EDT
This does not need to be private
Comment 4 Petr Muller 2013-08-19 10:53:23 EDT
This brough 4 fails in the suite. Note to myself: test even trivial stuff.
Comment 5 Petr Muller 2013-08-20 09:43:22 EDT
The FILE variable should have been local, or it leaks outside, rewriting possible user setting.

https://git.fedorahosted.org/cgit/beakerlib.git/commit/?id=d8af6aef05608d28efc3c8afc7f4fd7d5c0e92ea
Comment 6 Fedora Update System 2014-06-17 09:41:21 EDT
beakerlib-1.9-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/beakerlib-1.9-1.fc20
Comment 7 Fedora Update System 2014-06-17 19:28:52 EDT
Package beakerlib-1.9-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing beakerlib-1.9-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7442/beakerlib-1.9-1.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-07-02 04:01:01 EDT
beakerlib-1.9-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/beakerlib-1.9-2.fc20
Comment 9 Dalibor Pospíšil 2014-07-04 04:51:00 EDT
Please consider the package fixing this bug available in Fedora stable repos once bz1116308 is closed and RHEL stable repos once bz1116317 is closed.

Fixed in:
beakerlib-1.9-2.fc19
beakerlib-1.9-2.fc20
beakerlib-1.9-2.fc21
beakerlib-1.9-3.el5
beakerlib-1.9-2.el6
beakerlib-1.9-2.el7
Comment 10 Fedora Update System 2014-07-17 09:15:32 EDT
beakerlib-1.9-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/beakerlib-1.9-3.fc20
Comment 11 Fedora Update System 2014-07-30 02:57:02 EDT
beakerlib-1.9-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.