Bug 988772 - SMB:iozone hung on SMB mount on linux client
SMB:iozone hung on SMB mount on linux client
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Raghavendra Talur
surabhi
:
Depends On:
Blocks: 956495
  Show dependency treegraph
 
Reported: 2013-07-26 06:34 EDT by surabhi
Modified: 2013-09-23 18:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description surabhi 2013-07-26 06:34:25 EDT
Description of problem:
Iozone gets hung when it is executed on 6x2 distributed replicate volume which is mounted via smb on a linux client.

Version-Release number of selected component (if applicable):

[root@dhcp159-0 ~]# rpm -qa | grep glusterfs
glusterfs-devel-3.4.0.12rhs.beta6-1.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.12rhs.beta6-1.el6rhs.x86_64
samba-glusterfs-3.6.9-155.5.el6rhs.x86_64
glusterfs-fuse-3.4.0.12rhs.beta6-1.el6rhs.x86_64
glusterfs-server-3.4.0.12rhs.beta6-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.12rhs.beta6-1.el6rhs.x86_64
glusterfs-3.4.0.12rhs.beta6-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.12rhs.beta6-1.el6rhs.x86_64

[root@dhcp159-0 ~]# uname -a
Linux dhcp159-0.sbu.lab.eng.bos.redhat.com 2.6.32-358.14.1.el6.x86_64 #1 SMP Mon Jun 17 15:54:20 EDT 2013 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
3/3

Steps to Reproduce:
1.Do a ctdb setup.
2.create a 6x2 dis-rep volume and do a cifs mount on the client with virtual ip corresponding to the physical ip on which the volume is created.
3.Run iozone on the mount point.

Actual results:
Iozone gets hung forever.

Expected results:
Iozone should pass.

Additional info:
Running this on windows as well. taking too long not yet passed. Will post the results.
Comment 3 surabhi 2013-08-14 06:01:35 EDT
Executed Iozone on :

samba-glusterfs-3.6.9-156.2.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-libs-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-api-devel-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-devel-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-api-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.18rhs-1.el6rhs.x86_64
glusterfs-server-3.4.0.18rhs-1.el6rhs.x86_64

/mnt/samba/dis-rep/run1250
iozone
executing iozone
start:02:32:59

real    83m58.333s
user    0m3.540s
sys     2m41.698s
end:03:56:57
1
Total 1 tests were successful

The hang was not seen and the test passed on both linux cifs client and windows.
Comment 4 surabhi 2013-08-16 04:31:52 EDT
With the version :
samba-glusterfs-3.6.9-159.1.el6rhs.x86_64
glusterfs-3.4.0.19rhs-2.el6rhs.x86_64

The iozone test passed on both windows and linux client.
Comment 5 Scott Haines 2013-09-23 18:32:16 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.