Bug 988778 - Report broken dependencies
Report broken dependencies
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 871892
  Show dependency treegraph
 
Reported: 2013-07-26 06:47 EDT by Miroslav Suchý
Modified: 2015-11-11 19:47 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 08:01:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2013-07-26 06:47:18 EDT
Description of problem:
If you have broken dependencies, dnf will not report it, so user will never get that information.

Yum does:

--> Finished Dependency Resolution
--> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error: xorg-x11-drv-nvidia conflicts with xorg-x11-drv-nvidia-304xx-304.88-12.fc19.x86_64
Error: Package: rhn-sat-cert-sign-0.3-6.el6.noarch (installed)
           Requires: PyXML
           Removing: PyXML-0.8.4-28.fc18.x86_64 (@fedora/18)
               PyXML = 0.8.4-28.fc18
           Obsoleted By: python-2.7.5-3.fc19.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:

And dnf does:

Transaction Summary
==================================================================================================================================================
Upgrade  61 Packages

Total download size: 75 M
Is this ok [y/N]:

I'm not saying that dnf must behave exactly like yum. But at least some report would be nice. E.g. something like would be nice:
  Upgrade  61 Packages
  Warning: rhn-sat-cert-sign, xorg-x11-drv-nvidia skipped due unmet dependencies (run dnf --full-info for more information)

Version-Release number of selected component (if applicable):
dnf-0.3.9-1.giteff4c49.fc19.noarch

How reproducible:
deterministic

Steps to Reproduce:
I installed rhn-sat-cert-sign on F18 and run fedora-upgrade, but this is probably minimalistic reproducer:
1. Install rhn-sat-cert-sign and python and PyXML from F18 to F19
2. yum upgrade
Comment 2 Ales Kozumplik 2013-07-26 08:01:38 EDT
Hi Miroslav,

this is the desired behavior, DNF chooses not to display dependency errors in the latest packages by default. This is with the majority of users in mind. Maintainers and other power users can use '--best'. This has been discussed and documented already, please see:

https://bugzilla.redhat.com/show_bug.cgi?id=872948
https://bugzilla.redhat.com/show_bug.cgi?id=882211
http://akozumpl.github.io/dnf/cli_vs_yum.html#no-skip-broken

I'm going to close this as NOTABUG.
Comment 3 Ales Kozumplik 2014-04-04 08:19:38 EDT
*** Bug 1084129 has been marked as a duplicate of this bug. ***
Comment 4 Ales Kozumplik 2014-04-06 07:46:47 EDT
*** Bug 1084129 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.