Bug 988789 - Review Request: rubygem-hoptoad_notifier - Send your application errors to our hosted service and reclaim your inbox
Review Request: rubygem-hoptoad_notifier - Send your application errors to ou...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Josef Stribny
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 07:17 EDT by Miroslav Suchý
Modified: 2016-01-04 00:51 EST (History)
4 users (show)

See Also:
Fixed In Version: rubygem-hoptoad_notifier-2.4.11-5.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-14 22:45:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jstribny: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2013-07-26 07:17:02 EDT
Spec URL: http://miroslav.suchy.cz/fedora/rubygem-hoptoad_notifier/rubygem-hoptoad_notifier.spec
SRPM URL: http://miroslav.suchy.cz/fedora/rubygem-hoptoad_notifier/rubygem-hoptoad_notifier-2.4.11-3.fc19.src.rpm
Description: 
This is the notifier plugin for integrating apps with Hoptoad.
When an uncaught exception occurs, HoptoadNotifier will POST the relevant data
to the Hoptoad server specified in your environment.

Fedora Account System Username: msuchy

Koji scratch build:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5659598

Note: I know that this package is obsolete by Airbrake, but that have non-free license. And this is last version of free code. I'm willing so maintain it in Fedora despite the support from upstream.
Comment 1 Josef Stribny 2013-08-02 04:28:02 EDT
Taking.
Comment 2 Josef Stribny 2013-08-05 04:29:30 EDT
Testing this package is difficult since it's built against Rails 2 and automatic tests cannot be run easily. Since you expressed that there are people using it with Rails 4.0, it can be used in non-Rails apps as well and since I didn't encounter any errors when playing with it I believe this package can get to Fedora, although it might be difficult to keep it in shape in future. Because you want to maintain it despite the support from upstream, I have no objections.

Please fix the following:

* Carry the license file with the package
  Move %doc %{gem_instdir}/MIT-LICENSE to main package

* Description of the doc sub-package should end up with a dot.

Otherwise the package builds and installs with the upcoming Rails 4.0 update and spec seems to be fine.
Comment 4 Josef Stribny 2013-08-05 09:30:29 EDT
APPROVED.
Comment 5 Miroslav Suchý 2013-08-05 09:45:24 EDT
New Package SCM Request
=======================
Package Name: rubygem-hoptoad_notifier
Short Description: Send your application errors to our hosted service and reclaim your inbox
Owners: msuchy
Branches: f19
InitialCC:
Comment 6 Gwyn Ciesla 2013-08-05 10:27:42 EDT
Git done (by process-git-requests).
Comment 7 Fedora Update System 2013-08-05 11:15:04 EDT
rubygem-hoptoad_notifier-2.4.11-5.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rubygem-hoptoad_notifier-2.4.11-5.fc19
Comment 8 Fedora Update System 2013-08-06 19:32:05 EDT
rubygem-hoptoad_notifier-2.4.11-5.fc19 has been pushed to the Fedora 19 testing repository.
Comment 9 Fedora Update System 2013-08-14 22:45:34 EDT
rubygem-hoptoad_notifier-2.4.11-5.fc19 has been pushed to the Fedora 19 stable repository.

Note You need to log in before you can comment on or make changes to this bug.