Bug 988795 - GNOME printer settings asks for *wrong* password
GNOME printer settings asks for *wrong* password
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-07-26 07:44 EDT by David Woodhouse
Modified: 2015-02-17 11:22 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-02-17 11:22:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2013-07-26 07:44:31 EDT
dwmw2:x:500:500:David Woodhouse:/home/dwmw2:/bin/bash
dwoodhou:x:501:501:David Woodhouse:/home/dwoodhou:/bin/bash

These users have *different* passwords. One is my local user that I've always used; the other uses pam_winbind and is present on the system for testing purposes.

I log in as the 'dwmw2' user except when testing Active Directory integration.

On adding a printer yesterday, I clicked 'unlock' in the printer settings dialog in gnome-control-center. It popped up a dialog asking for the password for "David Woodhouse". And it accepted the password for 'dwoodhou', and *not* the password for 'dwmw2'.

Today, on attempting to reproduce this for filing the bug, I get a different failure mode. The 'unlock' button is greyed out, if I run gnome-control-center from the GNOME shell menu. And if I run it from the command line with the '-v' option, the 'unlock' button is active, but triggers the following output:

(gnome-control-center:897): Gtk-WARNING **: Error acquiring permission: Failed to acquire permission for action-id org.opensuse.cupspkhelper.mechanism.all-edit
Comment 1 David Woodhouse 2013-07-26 16:05:09 EDT
After a reboot, polkit appears to be behaving again, and I can see the original (wrong user) behaviour again.

When I successfully authenticate by giving the wrong user's password, /var/log/secure says:

Jul 26 21:03:17 i7 polkitd[1598]: Operator of unix-session:3 successfully authenticated as unix-user:dwoodhou to gain TEMPORARY authorization for action org.opensuse.cupspkhelper.mechanism.all-edit for unix-process:4858:855655 [gnome-control-center --overview] (owned by unix-user:dwmw2)
Comment 2 David Woodhouse 2013-07-29 09:43:02 EDT
This happens when virt-manager is asking for "my" password too.
Comment 3 David Woodhouse 2013-08-01 10:18:02 EDT
I have "fixed" this issue by adding my dwmw2 account to the wheel group.

Apparently it is "expected" behaviour, that polkit/gnome-shell will ask for the password of some *other* user just because that user happens to be in the wheel group, rather than asking for the root password.

This is bizarre and wrong!
Comment 4 Fedora End Of Life 2015-01-09 14:06:37 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 5 Fedora End Of Life 2015-02-17 11:22:11 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.