This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988817 - FormRenderContext is not serializable
FormRenderContext is not serializable
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER2
: 6.0.0
Assigned To: Pere Fernàndez
Marek Baluch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 09:24 EDT by Maciej Swiderski
Modified: 2014-08-06 16:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:12:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPM-4076 Major Resolved FormRenderContext is not serializable which causes issues with session replication on EAP6.1 2014-09-09 02:52:32 EDT

  None (edit)
Description Maciej Swiderski 2013-07-26 09:24:51 EDT
Description of problem:

FormRenderContext is not serializable which causes issues with session replication on EAP6.1

How reproducible:
see linked jira for details

Actual results:
lots of error written in logs due to not serializable object

Expected results:


Additional info:
https://issues.jboss.org/browse/JBPM-4076
Comment 2 Pere Fernàndez 2013-08-06 13:25:11 EDT
Refactored the FormRenderContext / FormEditContext management to make it Serializable.

Commits:
https://github.com/droolsjbpm/jbpm-form-modeler/commit/30a37c016ad407e8c727fa9bb490b39f9b5808e5
Comment 3 JBoss JIRA Server 2013-08-12 11:05:28 EDT
Pere Fernández Pérez <pere.fernandez@gmail.com> updated the status of jira JBPM-4076 to Resolved
Comment 4 JBoss JIRA Server 2013-08-12 11:05:28 EDT
Pere Fernández Pérez <pere.fernandez@gmail.com> made a comment on jira JBPM-4076

Canged the FormRenderContext & FormEditorContext to make them Serializable.

Commit: https://github.com/droolsjbpm/jbpm-form-modeler/commit/165732edf7604e38e73f78bc51a33c2e0ad6f883
Comment 5 Marek Baluch 2013-09-04 08:12:13 EDT
Verified on ER2.

Note You need to log in before you can comment on or make changes to this bug.