Bug 98882 - /etc/bashrc overrides any "stty erase" setting
/etc/bashrc overrides any "stty erase" setting
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: setup (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-09 16:41 EDT by Chris Adams
Modified: 2014-03-16 22:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-06 23:20:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Adams 2003-07-09 16:41:50 EDT
/etc/bashrc contains a section that sets the "erase" setting based on the
terminfo entry for the terminal.  The problem is that this overrides "stty
erase" settings from other sources (such as a remote connection via ssh, where
OpenSSH properly carries forward the "erase" setting).  There is currently no
way for a normal user to fix this; root must override it by editing /etc/bashrc.

Would it be possible to at least make this section dependent on an environment
variable or something, so those of us that don't want it can avoid it (without
having to edit /etc/bashrc on every install)?
Comment 1 Adam Spiers 2004-01-06 17:48:07 EST
This is surely a duplicate of bug #91357.
Comment 2 Chris Adams 2004-01-06 23:20:27 EST
Thanks.  I did look for an existing bug (honest!) but I didn't see it.
 Just checked the FC dev setup-2.5.30 and see the change has been made.

Note You need to log in before you can comment on or make changes to this bug.