This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 988856 - crash-devel should require lzo-devel etc.
crash-devel should require lzo-devel etc.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: crash (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dave Anderson
Guangze Bai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 10:56 EDT by Frank Ch. Eigler
Modified: 2015-02-08 16:39 EST (History)
3 users (show)

See Also:
Fixed In Version: crash-7.0.1-4.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 02:45:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frank Ch. Eigler 2013-07-26 10:56:49 EDT
crash/defs.h in 7.0+ includes a hard-coded

#define LZO
#ifdef LZO
#include <lzo/lzo1x.h>
#endif

and the same for something called SNAPPY

So those are de-facto prerequisites of crash-devel, yet are not listed as such.
So when a crash-devel-user's autoconf tests crash/defs.h usability, it
fails in a sad, tragic, and frankly tear-jerking fashion.  Please either add the
Requires:, or else drop the unconditional #define's.
Comment 1 Dave Anderson 2013-07-26 11:06:07 EDT
Thanks Frank.

The base package has:

  BuildRequires: ncurses-devel zlib-devel lzo-devel bison snappy-devel
  Requires: binutils

The crash-devel package has:

  %package devel
  Requires: %{name} = %{version}, zlib-devel

Should the lzo-devel and snappy-devel be added to the crash-devel
Requires line?  And if so, why don't the ncurse-devel and bison
additions also cause a problem?
Comment 3 Dave Anderson 2013-07-26 11:10:43 EDT
Never mind bison and ncurses-devel -- those are for building crash whereas
the lzo-devel and snappy-devel packages are (new) run-time functionality.

But please confirm that you're referencing the crash-devel Requires line
and not the base package Requires line.
Comment 4 Frank Ch. Eigler 2013-07-26 11:47:38 EDT
I do mean the crash-devel requires line, since it's the header file that requires other header files.

(A buildrequires from the base package wouldn't help crash-devel users anyway, as we're not trying to build crash.)

Note You need to log in before you can comment on or make changes to this bug.