Bug 988908 - libvirt shuts down host when trying to shut down lxc guest
libvirt shuts down host when trying to shut down lxc guest
Status: CLOSED WORKSFORME
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 12:45 EDT by Florian Klink
Modified: 2016-04-09 20:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-09 20:23:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
libvirt lxc xml file (1.05 KB, text/xml)
2013-07-26 12:56 EDT, Florian Klink
no flags Details

  None (edit)
Description Florian Klink 2013-07-26 12:45:52 EDT
Description of problem: When I try to shutdown (or reboot) LXC guest, my host machine shuts down (or reboots).

I don't know if it's related to c9c87376f2b2197ad774533ad6a6dd2f631ca105 (reverted with edd87fa2ea14309be5f87847d35ef8cc10a99322)

Gentoo amd64
libvirt-1.1.0-r3
lxc-0.8.0-r1


How reproducible:


Steps to Reproduce:
1. Create lxc container (I used virt-manager)
2. Container type: Operating system container
3. Directory volume: dir to gentoo stage3 chroot
4. start container
5. choose shut down -> shutdown/reboot

Actual results:
Host machine shuts down /reboots

Expected results:
Only container shuts down/reboots
Comment 1 Florian Klink 2013-07-26 12:56:21 EDT
Created attachment 778837 [details]
libvirt lxc xml file
Comment 2 Cole Robinson 2016-04-09 20:23:30 EDT
Sorry this didn't receive a timely response. I can't reproduce this myself and haven't heard any reports like this recently, so I assume this was fixed in libvirt at some point. If anyone can still reproduce with modern versions, please reopen

Note You need to log in before you can comment on or make changes to this bug.