Bug 988986 - libvirt network directory is not persisted
Summary: libvirt network directory is not persisted
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Joey Boggs
QA Contact: Martin Pavlik
URL:
Whiteboard: node
Depends On:
Blocks: 918494
TreeView+ depends on / blocked
 
Reported: 2013-07-26 20:40 UTC by Antoni Segura Puimedon
Modified: 2015-12-02 13:33 UTC (History)
14 users (show)

Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:31 UTC
oVirt Team: ---


Attachments (Terms of Use)

Description Antoni Segura Puimedon 2013-07-26 20:40:39 UTC
Description of problem:
To be able to have vdsm networking across reboots libvirt network directory must be persisted, i.e., there should be /config/etc/libvirt/qemu/networks/

Version-Release number of selected component (if applicable):
ovirt-node-iso-3.0.0-5.0.5.vdsm.fc19.iso

How reproducible: 100%


Steps to Reproduce:
1. Install ovirt-node.
2. Add it to an engine.
3. Add a network


Actual results:
/config/etc/libvirt/qemu/ does not exist

Expected results:
/config/etc/libvirt/qemu/ exists and contains the networks.

Additional info:

Comment 1 Mike Burns 2013-07-26 20:58:20 UTC
it appears ovirt_store_firstboot_config is not getting run in the boot process.  We're calling out to the new tui which i think is preventing this from running.  It may need to be moved to a python function instead.

We should also check to make sure the other things in ovirt-firstboot are getting executed correctly.

Comment 2 Joey Boggs 2013-07-31 19:08:53 UTC
We save the same list of files/dirs from the bash scripts now in finish_install().

disable_firstboot is being run just not the storing of ovirt_firstboot_config and that's the last in the list. Suspect reboot delay is not long enough or some other process is killing it. Tried 15 secs delay and still same effect.

http://gerrit.ovirt.org/17547

Comment 3 Martin Pavlik 2014-02-25 12:01:28 UTC
verified

[root@dell-r210ii-06 ~]# cat /etc/redhat-release 
oVirt Node Hypervisor release 3.0.3 (0.999.201401221941draft.el6) (Edited)[root@dell-r210ii-06 ~]# ls -lad /config/etc/libvirt/qemu/
drwxr-xr-x. 3 root root 1024 2014-02-25 11:40 /config/etc/libvirt/qemu/

Comment 4 Sandro Bonazzola 2014-03-31 12:23:31 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.