Bug 989019 - imapsync EPEL update fails due to missing dependencies
imapsync EPEL update fails due to missing dependencies
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: imapsync (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Marek Mahut
Fedora Extras Quality Assurance
:
: 990633 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-26 19:17 EDT by Michal Jaegermann
Modified: 2013-08-03 15:14 EDT (History)
7 users (show)

See Also:
Fixed In Version: perl-Data-Uniqid-0.12-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 16:37:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2013-07-26 19:17:09 EDT
Description of problem:

An attempt to update from a present imapsync to a newly provided update produces the following:

Resolving Dependencies
--> Running transaction check
---> Package imapsync.noarch 0:1.542-1.el6 will be updated
---> Package imapsync.noarch 0:1.547-1.el6 will be an update
--> Processing Dependency: perl(Data::Uniqid) for package: imapsync-1.547-1.el6.noarch
--> Finished Dependency Resolution
Error: Package: imapsync-1.547-1.el6.noarch (epel)
           Requires: perl(Data::Uniqid)

Version-Release number of selected component (if applicable):
imapsync-1.547-1.el6

Additional info:
perl-Data-Uniqid-0.12-2.el6 is available in koji with a "Build Date: Tue 21 May 2013", and after installing it an update in question does not have any issues, but that package is somehow missing from EPEL repos.
Comment 1 Pavel Lisý 2013-07-29 06:37:17 EDT
It looks like problem with karma, please add your voice there too:
https://admin.fedoraproject.org/updates/perl-Data-Uniqid-0.12-2.el5?_csrf_token=ff9b5f077ebf60111534b7fc2212eade443a64e1
Comment 2 Michal Jaegermann 2013-07-29 11:22:18 EDT
(In reply to Pavel Lisý from comment #1)
>  please add your voice there too:

That is clearly beyond my abilities.  Whatever I am trying to do https://admin.fedoraproject.org/ is unhappy.
Comment 4 Nick Bebout 2013-08-01 10:33:51 EDT
I mistakenly forgot to push perl-Data-Uniqid to EPEL.  It is pushed to testing now.  Please leave karma in bodhi so I can push it to stable quicker.
Comment 5 Nick Bebout 2013-08-01 10:35:16 EDT
*** Bug 990633 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-08-01 10:38:15 EDT
perl-Data-Uniqid-0.12-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/perl-Data-Uniqid-0.12-2.el6
Comment 7 Fedora Update System 2013-08-01 10:40:28 EDT
perl-Data-Uniqid-0.12-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/perl-Data-Uniqid-0.12-2.el5
Comment 8 Fedora Update System 2013-08-01 16:34:58 EDT
Package perl-Data-Uniqid-0.12-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing perl-Data-Uniqid-0.12-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11034/perl-Data-Uniqid-0.12-2.el6
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2013-08-01 16:37:08 EDT
perl-Data-Uniqid-0.12-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2013-08-03 15:14:42 EDT
perl-Data-Uniqid-0.12-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.