Bug 989046 - nokogiri prints LibXML warning
nokogiri prints LibXML warning
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rubygem-nokogiri (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 01:32 EDT by Ken Dreyer
Modified: 2014-02-06 23:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 23:44:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Dreyer 2013-07-27 01:32:23 EDT
On Fedora 19, with the following packages:

libxml2-2.9.1-1.fc19.i686
rubygem-nokogiri-1.5.9-1.fc19.i686

Any scripts using nokogiri print a warning that nokogiri was built against a different libxml version. A simple reproduction case:

$ ruby -rnokogiri -e ''
WARNING: Nokogiri was built against LibXML version 2.9.0, but has dynamically loaded 2.9.1

Koji confirms that nokogiri was indeed originally built against libxml2-2.9.0-4.fc19: http://kojipkgs.fedoraproject.org//packages/rubygem-nokogiri/1.5.9/1.fc19/data/logs/i686/root.log

My guess is that a simple rebuild for F19 would fix this.
Comment 1 Ken Dreyer 2014-02-06 23:44:48 EST
Looks like this is no longer an issue on Fedora 20 (rubygem-nokogiri-1.6.1-1.fc20.1)

$ ruby -rnokogiri -e ''

is silent.

Note You need to log in before you can comment on or make changes to this bug.