Bug 98911 - redhat-config-users will delete 'users' group (GID 100)
redhat-config-users will delete 'users' group (GID 100)
Status: CLOSED DUPLICATE of bug 78620
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-10 02:38 EDT by Joshua Penix
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Penix 2003-07-10 02:38:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
When users are created without matching private groups (an option during account
creation), their primary group is set to the 'users' group, GID 100.

During deletion of users through redhat-config-users, if the user being deleted
has his primary group set to 100, and that user is the only user in group 100,
then group 100 is deleted along with the user.

Additionally, redhat-config-users itself becomes confused when GID 100 is
missing and future users are created with the "Create a private group for the
user" checkbox unchecked.  In this situation, redhat-config-users goes into an
endless loop and needs to be killed.

Version-Release number of selected component (if applicable):
redhat-config-users-1.1.5-7

How reproducible:
Always

Steps to Reproduce:
1. Ensure there are no users in group 'users', gid 100
2. Add a user with redhat-config-users and clear the 'Create a private group for
the user' checkbox
3. Verify that the new users has GID 100 as their primary group, and that they
are listed in /etc/groups under 100
4. Use redhat-config-users to delete the same user
5. Verify that /etc/groups now has no entry for GID 100!!
6. Use redhat-config-users to create another user, once again clearing the
'Create a private group for the user' checkbox
7. Watch redhat-config-users go into endless loop
Comment 1 Brent Fox 2003-07-11 16:42:28 EDT
I added code to cvs on April 3, 2003 to fix this bug.  This is a dupe of bug
78620.  A new version is available in Rawhide to fix this problem.

*** This bug has been marked as a duplicate of 78620 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:00 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.