Bug 989111 - dnf ignores rpmfusion without warning
dnf ignores rpmfusion without warning
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 12:23 EDT by Jiri Moskovcak
Modified: 2015-02-01 17:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 11:08:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Moskovcak 2013-07-27 12:23:13 EDT
Description of problem:
I just tried dnf update and it doesn't update packages from rpmfusion. If I run yum update the resulting transaction contains packages from rpmfusion, so it seems the repositories are ok.


Version-Release number of selected component (if applicable):
dnf-0.3.9-1.giteff4c49.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. run dnf check-update
2. run yum check-update
3. diff the outputs and look for missing packages from rpmfusion

Actual results:
it doesn't update kmod-nvidia from rpmfusion which on machine results in non-functional Xorg

Expected results:
all packages updated

Additional info:
I tried even dnf update --best, which gave me the same result as without it
Comment 1 Ales Kozumplik 2013-07-29 07:00:34 EDT
Hello Jiri, 

thank you for the report. I tried reproducing it but for me rpmfusion packages seem to update fine (see the end of this post). Since you told me you've updated the system in the meantime we can't do much to debug this now but the next time you run into this problem please rerun the dnf operation with '--debugsolver' and attach the debugdata directory dnf creates in your current working directory. Also, does this happen with all rpmfusion packages or just kmod-nvidia (which uses not quite common versioning as I can see)?


---

[akozumpl@localhost ~]$ dnf list installed openafs
Installed Packages
openafs.x86_64                                         1.6.2.1-1.fc19                                         @System

yet:

[akozumpl@localhost ~]$ dnf upgrade openafs
Setting up Upgrade Process
Resolving Dependencies
--> Starting dependency resolution
---> Package openafs.x86_64 1.6.2.1-1.fc19 will be upgraded
---> Package openafs.x86_64 1.6.4-1.fc19 will be an upgrade
--> Finished dependency resolution

...
Comment 2 Ales Kozumplik 2013-09-11 11:08:03 EDT
Closing this now, it's been in needinfo for over a month. If the problem reappears feel free to reopen and please attach the debug data requested above.

Note You need to log in before you can comment on or make changes to this bug.