Bug 989142 - VioSCSI device is missing from the hwdata PCI IDS DB, and thus is not shown properly in the output of lspci
Summary: VioSCSI device is missing from the hwdata PCI IDS DB, and thus is not shown p...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: hwdata
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michal Minar
QA Contact: Lukas "krteknet" Novy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-07-27 20:58 UTC by Lev Veyde
Modified: 2014-02-18 23:56 UTC (History)
2 users (show)

Fixed In Version: hwdata-0.233-8.0.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-11-21 11:16:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1612 normal SHIPPED_LIVE hwdata bug fix and enhancement update 2013-11-20 21:39:00 UTC

Description Lev Veyde 2013-07-27 20:58:11 UTC
Description of problem:
The information about RedHat Virtio SCSI device (1af4:1004) is missing from hwdata PCI IDS DB provided with the OS release, and thus no proper info is shown by i.e. lspci utility.

Version-Release number of selected component (if applicable):
RHEL 6.4
hwdata-0.233-7.9.el6.noarch

How reproducible:
Always.

Steps to Reproduce:
1. run lspci in a VM with VioSCSI device present.
2. note that the device appears as Device 1004, instead of the proper name i.e. "Virtio SCSI"

Actual results:
Device name is not shown properly. Numeric device id is shown instead.

Expected results:
A proper device name should be shown.

Additional info:
The device appears in the updated PCI IDS DB, and as a workaround the updated DB can be manually installed by i.e. update-pciids.

Comment 2 Michal Minar 2013-07-29 05:09:29 UTC
Thanks for this report. As you mentioned, it's already in upstream. No problem pulling it to the new build.

Comment 7 errata-xmlrpc 2013-11-21 11:16:09 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1612.html


Note You need to log in before you can comment on or make changes to this bug.