Bug 989152 - lightdm: cursor theme doesn't change
lightdm: cursor theme doesn't change
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
: Reopened
: 970023 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 21:07 EDT by Neil
Modified: 2015-06-13 03:12 EDT (History)
9 users (show)

See Also:
Fixed In Version: lightdm-kde-0.3.2.1-8.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-06-13 03:00:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
secondpic (39.99 KB, image/jpeg)
2013-07-27 21:08 EDT, Neil
no flags Details
firstpic (889.38 KB, image/png)
2013-07-27 21:10 EDT, Neil
no flags Details
index.theme (486.45 KB, image/png)
2015-06-13 02:42 EDT, Neil
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1024482 None None None Never
Debian BTS 671121 None None None Never
Debian BTS 742460 None None None Never

  None (edit)
Description Neil 2013-07-27 21:07:47 EDT
Just that, the cursor theme doesn't want to change, but something curious is that how you can see in the first picture, apparently the cursor theme changed, but, just in the screenshot, so I take another screenshot but with my webcam, and how you can see, the cursor didn't changed at all, I just noticed that the theme just work when I put the cursor on my Firefox window, if I put it on, Caja, or I don't know, Gimp, Clementine, etc, etc, the cursor keep having the Adwaita theme.

(This happen with ALL cursor themes.)

"mate-themes-1.6.1-2.fc19"
Comment 1 Neil 2013-07-27 21:08:50 EDT
Created attachment 779241 [details]
secondpic
Comment 2 Neil 2013-07-27 21:10:11 EDT
Created attachment 779242 [details]
firstpic
Comment 3 Wolfgang Ulbrich 2013-07-28 05:53:57 EDT
This is known issue, i send it to upstream.
https://github.com/mate-desktop/mate-settings-daemon/issues/46
Comment 4 Wolfgang Ulbrich 2013-07-29 12:05:46 EDT
As first workaround you can edit
[rave@mother ~]$ cat /usr/share/icons/default/index.theme 
[Icon Theme]
Inherits=Adwaita

Change here the theme to whatever you want.
But this isn't the real issue.
Comment 5 Wolfgang Ulbrich 2013-07-29 12:06:16 EDT
and restart X.
Comment 6 Neil 2013-08-02 14:52:11 EDT
thanks it worked.
Comment 7 Wolfgang Ulbrich 2013-08-09 19:15:06 EDT
*** Bug 970023 has been marked as a duplicate of this bug. ***
Comment 8 Neil 2014-01-14 20:45:47 EST
This bug still present on Fedora 20.
Comment 9 Neil 2014-07-10 18:23:12 EDT
Bug is present also on Cinnamon.
Comment 10 Neil 2014-08-24 13:24:24 EDT
bug is not present if you don't install the Cinnamon group. (Using Cinnamon recently installed on a minimal install)
Comment 11 Wolfgang Ulbrich 2014-08-24 16:02:38 EDT
Which display manager you're using?
I ask because i played a bit around today and it seems that lightdm is the culprit.
If i set lightdm to autologin for a user i can switch the cursor theme in both desktops, mate and cinnamon.
If i use 'sddm' as DM everything works well without setting autologin.
So it seems that lightdm sets the cursor and it is present afer login.
Could you pls confirm that?
Comment 12 Neil 2014-08-24 21:14:45 EDT
Ha, pretty interesting, yep, actually I'm not using any display manager, uhm, I've made two different Fedora cinnamon installs today: A minimal install, and the other one with Cinnamon group installed (with weird dependencies like gnome deprecated stuff, anaconda, initial-setup, etc, can you guys remember when Cinnamon came up with ConsoleKit as dependency and we had a horrible delay after login?... maybe, just maybe, that was something wrong with lightdm too) and, the first one is really really stable and fast of course I installed some other packages like pulseaudio and things like that for sound), the second one isn't stable at all, and its really really buggy, many people use the NetInstall to have Cinnamon from their first boot, and sadly is the worst way to get it.
Comment 13 Neil 2014-08-30 19:54:42 EDT
Sorry, I don't know if I can ask this here but I want to know if that means that Fedora 21 will not have Cinnamon with MDM (Mint Display Manager) as Display Manager.
Comment 14 Wolfgang Ulbrich 2014-08-31 02:57:12 EDT
I'm not shure, but cinnamon use also lightdm if you install it directly from dvd or netiso.
But for questions about cinnamon you can ask at irc freenode channel fedora-mate. This channel is also for cinnamon and Leigh the maintainer is very often there.
Comment 15 Wolfgang Ulbrich 2014-09-07 10:32:50 EDT
I found out that also compiz sets the cursor theme. Starting the session from sddm or gdm and without compiz brings the mate cursor theme and i can happy switch the theme with mate-appearance properties.
But with compiz enable i can switch the theme with the ccsm configuration tool.
So compiz user have a possibility to switch the cursor theme. 
This doesn't work if lightdm is used as display manager.

To summarize:
1. Using lightdm in default configuration with any windows-manger, it's not possible to switch the cursor theme with mate-appearance properties or ccsm.
2. Using autologin in lightdm don't set the cursor theme and it's possible to switch the theme with mate-appearance properties (with marco) or ccsm (if compiz is running).
3. With ssdm or gdm as display manager (without autologin) we have the same situation as in (2).

OK, let see what lightdm maintainer thinks about that, maybe it is fixable.
Otherwise i'm thinking about switching to ssdm for f21.
Comment 16 Wolfgang Ulbrich 2014-09-07 10:35:39 EDT
Rex, do you see any chance that this is fixable?
Otherwise, using lightwight sddm sounds good for me.
Comment 17 Neil 2014-09-07 11:53:21 EDT
I see, well, sddm it's pretty cool, switching to sddm wouldn't be bad At all and can give some personality to Fedora's cinnamon spin.
Comment 18 Rex Dieter 2014-09-08 08:40:23 EDT
Based on comment #15, I don't see how the DM is related to the cursor theme at all honestly.  That's essentially a session task (to be handled by mate/cinnamon/whatever).

That said, I can say without reservation that changing default cursor theme to something other than the default fedora cursor theme (adwaita) is a very unfun problem (having explored doing so in kde spin), and would strongly encourage you to consider simply not doing it.  Doing it *right* (imho) would require changes/work in the libXcursor package (ie, owner of /usr/share/icons/default/index.theme )
Comment 19 Wolfgang Ulbrich 2014-09-08 12:46:54 EDT
There is no need to change /usr/share/icons/default/index.theme.
It is really the lightdm DM.
- system boots
- if no cursor theme is set in DM configuration the DM use what is writen in index.theme.
- session starts and use the theme which is set in mate-appearance properties and you can switch there the cursour theme as you like.

But this works only with sddm or gdm in my tests.
If i use lightdm, the DM hardcoded the setting in session, you can't switch the theme anymore. 
You can test it in a VM, it's 100% reproducable.
It has taken a very long time for me to find out that lightdm did cause the issue.
Also only with lightdm the cursor theme switch in session if you move over some apps, between what is set in index.theme and mate-appearance properties
Ie, with yumex or firefox you see the theme which is set in mate-appearance properties, if you move with the mouse over the empty desktop you see what is set in indextheme.

But i don't wanna make you unecessary work, if it's not fixable it's OK. I'm really thinking about switching to sddm for f21.
Switching the cursor theme is for me more important as a high configurable DM like lightdm, because this is a accessibility issue. Users with impaired vision absolutely depend on the ability to increase the mouse pointer size and color.
Also sddm is pretty nice lightwight and has very less dependencies.
Comment 20 Wolfgang Ulbrich 2014-09-08 12:49:46 EDT
Ps, user said it's the same with cinnamon.
Comment 21 leigh scott 2014-10-04 08:12:43 EDT
(In reply to Rex Dieter from comment #18)
> Based on comment #15, I don't see how the DM is related to the cursor theme
> at all honestly.  That's essentially a session task (to be handled by
> mate/cinnamon/whatever).

Does this expain it?

https://bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/1024482
Comment 22 Rex Dieter 2014-10-04 08:17:36 EDT
Interesting, ugh, ok, I'll follow those bugs and see if we can find some resolution.
Comment 23 Rex Dieter 2014-10-04 08:26:19 EDT
No luck, seems some folks have investigated the issue, and have a fair understanding of it.  There are some workarounds (with side-effects), but nothing yet that resembles a proper fix, as far as I can tell.
Comment 24 Wolfgang Ulbrich 2014-10-04 09:20:17 EDT
Rebuilding lightdm-gtk with gtk2 fixes the issue.
Now i can change the cursor theme with mate-appearance-properties.
Some scratch builds for testing.
http://koji.fedoraproject.org/koji/taskinfo?taskID=7762658
f20 build comming soon.
Comment 25 Wolfgang Ulbrich 2014-10-04 09:49:10 EDT
build for f20
http://koji.fedoraproject.org/koji/taskinfo?taskID=7762878
Comment 26 Fedora Update System 2014-10-05 09:45:55 EDT
lightdm-gtk-1.8.5-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/lightdm-gtk-1.8.5-6.fc21
Comment 27 Fedora Update System 2014-10-06 08:13:28 EDT
lightdm-gtk-1.8.5-8.fc20,lightdm-1.10.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lightdm-gtk-1.8.5-8.fc20,lightdm-1.10.2-1.fc20
Comment 28 glad08 2014-10-07 09:55:01 EDT
What about this issue in Fedora 19? 
https://bugzilla.redhat.com/show_bug.cgi?id=970023
Comment 29 Rex Dieter 2014-10-07 10:42:51 EDT
will be releasing an update/fix for f19 too.
Comment 30 Fedora Update System 2014-10-11 02:53:25 EDT
Package lightdm-kde-0.3.2.1-8.fc20, lightdm-gtk-1.8.5-9.fc20, lightdm-1.10.3-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lightdm-kde-0.3.2.1-8.fc20 lightdm-gtk-1.8.5-9.fc20 lightdm-1.10.3-1.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-12620/lightdm-kde-0.3.2.1-8.fc20,lightdm-gtk-1.8.5-9.fc20,lightdm-1.10.3-1.fc20
then log in and leave karma (feedback).
Comment 31 Fedora Update System 2014-10-11 03:03:00 EDT
lightdm-gtk-1.8.5-9.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2014-11-27 03:36:01 EST
lightdm-kde-0.3.2.1-8.fc20, lightdm-gtk-1.8.5-9.fc20, lightdm-1.10.3-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 33 Neil 2015-06-13 02:42:56 EDT
Created attachment 1038236 [details]
index.theme

almost the same bug, seems that cinnamon doesn't edit /usr/share/icons/default/index.theme it cannot be a lightdm issue since I've never installed a display/login manager.
Comment 34 leigh scott 2015-06-13 03:00:50 EDT
(In reply to Duff Padmasana from comment #33)
> Created attachment 1038236 [details]
> index.theme
> 
> almost the same bug, seems that cinnamon doesn't edit
> /usr/share/icons/default/index.theme 

Cinnamon has no right to edit this file, this is correct behavior. 

>it cannot be a lightdm issue since I've
> never installed a display/login manager.


Lightdm-gtk set it

diff -up lightdm-gtk-greeter-1.8.5/src/lightdm-gtk-greeter.c.lp#1024482 lightdm-gtk-greeter-1.8.5/src/lightdm-gtk-greeter.c
--- lightdm-gtk-greeter-1.8.5/src/lightdm-gtk-greeter.c.lp#1024482	2014-10-06 13:52:51.869311249 -0500
+++ lightdm-gtk-greeter-1.8.5/src/lightdm-gtk-greeter.c	2014-10-06 13:54:15.032163963 -0500
@@ -2267,6 +2267,9 @@ main (int argc, char **argv)
     /* Disable global menus */
     g_unsetenv ("UBUNTU_MENUPROXY");
 
+    /* LP: #1024482 */
+    g_setenv ("GDK_CORE_DEVICE_EVENTS", "1", TRUE);
+
     /* Initialize i18n */
     setlocale (LC_ALL, "");
     bindtextdomain (GETTEXT_PACKAGE, LOCALEDIR);

Note You need to log in before you can comment on or make changes to this bug.