Bug 989154 - Current wireshark rpm (wireshark-1.10.0-2.fc19.x86_64.rpm) fails to install binary
Current wireshark rpm (wireshark-1.10.0-2.fc19.x86_64.rpm) fails to install b...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
19
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 21:41 EDT by bob mckay
Modified: 2016-05-31 21:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-15 09:08:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bob mckay 2013-07-27 21:41:20 EDT
Description of problem: A yum install of wireshark currently installs all support files, but does not install the binary.

Version-Release number of selected component (if applicable):
wireshark-1.10.0-2.fc19.x86_64.rpm  

How reproducible:
Always

Steps to Reproduce:
1. Run "yum install wireshark" on an F19 system without wireshark

Actual results:
Wireshark support files (in /usr/lib64, /usr/share, /usr/man, /usr/doc) are installed, but the binary in /sbin->/usr/sbin is not installed.

Expected results:
The binary is installed.

Additional info:
I have tried this on three different machines, one real and two virtual, one a new install of F19, the other two upgrades from F18, with the same result each time. I'm happy to supply any additional information I can, but I couldn't find anything useful myself (nothing in /var/log/messages or yum.log indicating anything abnormal). I have also tried other installs of new packages, which all worked OK, so it doesn't seem to be a yum configuration problem, but rather specific to wireshark. Puzzlingly, the yum install also passes the verification stage with no errors.
Comment 1 Grzegorz Śmierzchalski 2013-08-12 03:18:40 EDT
Install wireshark-gnome. There is a binary
Comment 2 Peter Hatina 2013-08-15 09:08:52 EDT
Yes, Fedora splits Wireshark project into 2 packages:

Info from yum info wireshark*

* wireshark -- contains command-line utilities, plugins and documentation for wireshark.
* wireshark-gnome -- Gnome desktop integration for wireshark

Closing.
Comment 3 bob mckay 2013-08-15 20:35:47 EDT
You're right, I knew that, that's why it's working on my other machines... Please blame a senior moment (well maybe a senior hour or so 8^). On the other hand, perhaps we have a lot of seniors, newbies etc. using fedora, and maybe even wireshark.

So... please may I change this to an RFE (and a very small one).  

The behaviour of wireshark in this respect is somewhat anomalous. Abstractly, it consists of package xyz not installing the binary xyz, but instead, some other package (xyz-desktop, xyz-gnome or whatever) installing the binary xyz. Most packages don't do this - for most packages, if an xyz binary makes any sense, package xyz installs the binary xyz, and xyz-desktop installs something like xyz-desktop binary. I'm sure I'm not the only one for whom wireshark's unusual packaging has caused confusion.

How about having wireshark install a shell script like this, say in /usr/sbin or somewhere likely to be low priority on the user path:

#!/bin/sh

echo "wireshark binary does not exist"
echo "if you want it, you probably need to install a front-end such as wireshark-gnome"

and then have wireshark-gnome install over it...

Note You need to log in before you can comment on or make changes to this bug.