Bug 989155 - btrfs-progs: Support skinny extents via btrfstune -x
btrfs-progs: Support skinny extents via btrfstune -x
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: btrfs-progs (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Josef Bacik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-27 21:43 EDT by Alan Schmidt
Modified: 2013-09-29 20:38 EDT (History)
5 users (show)

See Also:
Fixed In Version: btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-29 20:38:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alan Schmidt 2013-07-27 21:43:38 EDT
New, exciting 3.10 kernel just made it to Fedora 19 updates.

One of the new, exciting features is skinny extents, the documentation for which explains that these can be enabled using "btrfstune -x".

However, the current version of btrfs-progs in Fedora-updates is not yet new enough to support this option.
Comment 1 Fedora Update System 2013-09-18 11:52:01 EDT
btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19
Comment 2 Eric Sandeen 2013-09-18 11:53:00 EDT
A new git snapshot of btrfs-progs has been pushed to F19 testing.  If possible, please re-test these bugs & feel free to close or comment as appropriate.

Thanks,
-Eric
Comment 3 Fedora Update System 2013-09-18 22:07:48 EDT
Package btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17126/btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19
then log in and leave karma (feedback).
Comment 4 Jan Welker 2013-09-20 09:59:58 EDT
I just enabled the skinny extends on my BTRFS volume and ran a balance to update the old extends. Turns out that this is not a good idea with the current Fedora kernel (3.10.11-200.fc19.x86_64) because the balance seg faults.

We should wait until the kernel patch "Btrfs: fix not being able to find skinny extents during relocate" is in the Kernel.
Comment 5 Eric Sandeen 2013-09-20 10:08:12 EDT
Thanks for testing.  As Josef would say, "welcome to using an experimental filesystem."  :(  (And this was one of my hesitations about plopping new userspace into Fedora, but *shrug* onward through the fog!)

FWIW,

aee68ee5f5427b91be5b23459993134ca64ecf00 Btrfs: fix not being able to find skinny extents during relocate

is in 3.11

-Eric
Comment 6 Fedora Update System 2013-09-29 20:38:51 EDT
btrfs-progs-0.20.rc1.20130917git194aa4a-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.