Bug 989198 - filesystem.x86_64 0:3.2-13.fc19 fails to update
filesystem.x86_64 0:3.2-13.fc19 fails to update
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: filesystem (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 04:27 EDT by sean_mccully
Modified: 2013-08-07 12:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 12:05:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean_mccully 2013-07-28 04:27:18 EDT
Description of problem:
Upgraded to Fedora 19, boot into fedora 19. Run yup update, and tries to update to -> filesystem.x86_64 0:3.2-13.fc19 from -> filesystem.x86_64 0:3.1-2.fc18

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. yum update
2.
3.

Actual results:
$ sudo yum update
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package filesystem.x86_64 0:3.1-2.fc18 will be updated
---> Package filesystem.x86_64 0:3.2-13.fc19 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

============================================================================================================================================================================
 Package                                   Arch                                  Version                                       Repository                              Size
============================================================================================================================================================================
Updating:
 filesystem                                x86_64                                3.2-13.fc19                                   updates                                1.0 M

Transaction Summary
============================================================================================================================================================================
Upgrade  1 Package

Total download size: 1.0 M
Is this ok [y/d/N]: y
Downloading packages:
Not downloading Presto metadata for updates
filesystem-3.2-13.fc19.x86_64.rpm                                                                                                                    | 1.0 MB  00:00:01     
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Updating   : filesystem-3.2-13.fc19.x86_64                                                                                                                            1/2 
Error unpacking rpm package filesystem-3.2-13.fc19.x86_64
error: unpacking of archive failed on file /lib: cpio: rename
filesystem-3.1-2.fc18.x86_64 was supposed to be removed but is not!
  Verifying  : filesystem-3.1-2.fc18.x86_64                                                                                                                             1/2 
  Verifying  : filesystem-3.2-13.fc19.x86_64                                                                                                                            2/2 

Failed:
  filesystem.x86_64 0:3.1-2.fc18                                                       filesystem.x86_64 0:3.2-13.fc19                                                      

Complete!


Expected results:
Not Failed

Additional info:
Comment 1 Ondrej Vasik 2013-08-07 04:28:21 EDT
Pretty strange, in both packages /lib should be (and is, I checked that) symlink to /usr/lib . Is that the case on your machine? I think this is something broken/user modified on your system, as otherwise I'm quite sure this will be not the only one report of this issue.
Comment 2 sean_mccully 2013-08-07 12:05:22 EDT
It is the problem is it was trying  to apply update while the current filesystem was in use and the when it was updating the sysmlink it obviously failed. This was due to an upgrade from F18 -> F19 borking at some point and booting into Failsafe.
Comment 3 sean_mccully 2013-08-07 12:06:22 EDT
I no longer type English well!!

Note You need to log in before you can comment on or make changes to this bug.