Bug 989204 - "nova interface-list" shows empty value in the interface's mac address field
"nova interface-list" shows empty value in the interface's mac address field
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-novaclient (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity medium
: beta
: 4.0
Assigned To: Brent Eagles
Roey Dekel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 06:47 EDT by Rami Vaknin
Modified: 2013-12-19 19:15 EST (History)
10 users (show)

See Also:
Fixed In Version: python-novaclient-2.15.0-1.el6ost
Doc Type: Bug Fix
Doc Text:
A python-novaclient bug prevented the 'nova interface-list' command from displaying MAC addresses. Specifically, the interface-list command incorrectly expected MAC address information in the JSON response to be in a column named 'mac_address'. However, the column was actually named 'mac_addr'. This prevented the 'nova interface-list' command from retrieving and, consequently, displaying MAC address information. With this fix, python-novaclient now expects MAC addresses from the correct 'mac_addr' column. This allows the 'nova interface-list' command to retrieve and display MAC address information.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:15:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1199706 None None None Never

  None (edit)
Description Rami Vaknin 2013-07-28 06:47:29 EDT
Version:
Grizzly on RHEL6.4, Neutron with OVS,
openstack-nova-api-2013.1.2-4.el6ost, openstack-quantum-2013.1.2-4.el6ost


Description:
The output of "nova interface-list <instance_id>" shows empty mac address althought other commands specify the mac address of the port associated with that interface.


# nova list --all-tenant
+--------------------------------------+------------+--------+---------------------------------------+
| ID                                   | Name       | Status | Networks                              |
+--------------------------------------+------------+--------+---------------------------------------+
| b79ebc09-0d64-495a-bf7c-34976eae1309 | vlan_211_0 | ACTIVE | net_vlan_211=10.35.211.2, 10.35.170.2 |
| 51e8e2b9-3eb1-4019-95e4-9384f9cc8a9e | vlan_211_1 | ACTIVE | net_vlan_211=10.35.211.4, 10.35.170.3 |
| 9d5dbd12-65a0-4c34-a59e-603dc8f11707 | vlan_212_0 | ACTIVE | net_vlan_212=10.35.212.2, 10.35.170.4 |
| ff675c74-076b-4c74-9dd5-da2348b5ed24 | vlan_212_1 | ACTIVE | net_vlan_212=10.35.212.4, 10.35.170.5 |
+--------------------------------------+------------+--------+---------------------------------------+
# nova interface-list b79ebc09-0d64-495a-bf7c-34976eae1309
+------------+--------------------------------------+--------------------------------------+--------------+-------------+
| Port State | Port ID                              | Net ID                               | IP addresses | MAC Address |
+------------+--------------------------------------+--------------------------------------+--------------+-------------+
| ACTIVE     | 44f72912-c6de-48a3-80fb-b026bcff9a46 | 8aa9d1f7-dca2-4245-b469-1073a66dd574 | 10.35.211.2  |             |
+------------+--------------------------------------+--------------------------------------+--------------+-------------+
# quantum port-show 44f72912-c6de-48a3-80fb-b026bcff9a46
+----------------------+------------------------------------------------------------------------------------+
| Field                | Value                                                                              |
+----------------------+------------------------------------------------------------------------------------+
| admin_state_up       | True                                                                               |
| binding:capabilities | {"port_filter": true}                                                              |
| binding:vif_type     | ovs                                                                                |
| device_id            | b79ebc09-0d64-495a-bf7c-34976eae1309                                               |
| device_owner         | compute:None                                                                       |
| fixed_ips            | {"subnet_id": "76abe891-2aaa-4dca-a40f-d5728219842c", "ip_address": "10.35.211.2"} |
| id                   | 44f72912-c6de-48a3-80fb-b026bcff9a46                                               |
| mac_address          | fa:16:3e:77:5c:6b                                                                  |
| name                 |                                                                                    |
| network_id           | 8aa9d1f7-dca2-4245-b469-1073a66dd574                                               |
| security_groups      | 0a48bfd8-7a08-4335-bd70-4b1b2d273087                                               |
| status               | ACTIVE                                                                             |
| tenant_id            | bc41451ac74847fc8c55016e60f0acc5                                                   |
+----------------------+------------------------------------------------------------------------------------+
Comment 2 Brent Eagles 2013-09-23 16:11:03 EDT
This was actually a novaclient issue and appears to have been fixed in the upstream source tree. I'm adding the external tracker for the issue, changing the component and setting to post for verification.
Comment 6 Roey Dekel 2013-11-07 11:09:59 EST
Verified on Havana 2013-10-28.2:
openstack-nova-api-2013.2-4.el6ost.noarch
openstack-neutron-2013.2-3.el6ost.noarch

nova interface-list show all the ports MAC Addr:

# nova list
+--------------------------------------+-----------+--------+------------+-------------+-------------------------+
| ID                                   | Name      | Status | Task State | Power State | Networks                |
+--------------------------------------+-----------+--------+------------+-------------+-------------------------+
| 8e4018ff-5656-422b-9af4-389fc97d4b1e | instance1 | ACTIVE | None       | Running     | netInt238=192.168.238.2 |
| 05b1e84d-5577-482b-9bdf-a0d2a44db02d | instance2 | ACTIVE | None       | Running     | netInt237=192.168.237.4 |
| ba08ad5c-42ef-4504-87ef-534afba24bec | instance3 | ACTIVE | None       | Running     | netInt238=192.168.238.5 |
| 3d337d3c-a666-4c31-a2ca-56fcdbda8ba2 | instance5 | ACTIVE | None       | Running     | netInt238=192.168.238.6 |
+--------------------------------------+-----------+--------+------------+-------------+-------------------------+

# nova interface-list 8e4018ff-5656-422b-9af4-389fc97d4b1e+------------+--------------------------------------+--------------------------------------+---------------+-------------------+
| Port State | Port ID                              | Net ID                               | IP addresses  | MAC Addr          |
+------------+--------------------------------------+--------------------------------------+---------------+-------------------+
| ACTIVE     | 528b3411-a243-4674-83db-7aaecb5cb6d0 | 75e4f2d2-7d7b-4cd6-89e6-5d31a893c367 | 192.168.237.2 | fa:16:3e:5b:e5:86 |
| ACTIVE     | 8ea7ee3b-42f2-4208-a33a-c20bea6d25f8 | 992071d2-115f-41a1-9ecd-47147045d586 | 192.168.238.2 | fa:16:3e:cf:95:d8 |
+------------+--------------------------------------+--------------------------------------+---------------+-------------------+

# neutron port-show 528b3411-a243-4674-83db-7aaecb5cb6d0
+-----------------------+--------------------------------------------------------------------------------------+
| Field                 | Value                                                                                |
+-----------------------+--------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                 |
| allowed_address_pairs |                                                                                      |
| binding:capabilities  | {"port_filter": true}                                                                |
| binding:host_id       | rose11.qa.lab.tlv.redhat.com                                                         |
| binding:vif_type      | ovs                                                                                  |
| device_id             | 8e4018ff-5656-422b-9af4-389fc97d4b1e                                                 |
| device_owner          | compute:None                                                                         |
| extra_dhcp_opts       |                                                                                      |
| fixed_ips             | {"subnet_id": "37eae6ec-e15b-46be-b965-514fd441efb4", "ip_address": "192.168.237.2"} |
| id                    | 528b3411-a243-4674-83db-7aaecb5cb6d0                                                 |
| mac_address           | fa:16:3e:5b:e5:86                                                                    |
| name                  |                                                                                      |
| network_id            | 75e4f2d2-7d7b-4cd6-89e6-5d31a893c367                                                 |
| security_groups       | 99f29033-e186-4a3d-ae89-029a0b4caeca                                                 |
| status                | ACTIVE                                                                               |
| tenant_id             | 80384d55b7554d9ab3d6190142a69d34                                                     |
+-----------------------+--------------------------------------------------------------------------------------+

# neutron port-show 8ea7ee3b-42f2-4208-a33a-c20bea6d25f8
+-----------------------+--------------------------------------------------------------------------------------+
| Field                 | Value                                                                                |
+-----------------------+--------------------------------------------------------------------------------------+
| admin_state_up        | True                                                                                 |
| allowed_address_pairs |                                                                                      |
| binding:capabilities  | {"port_filter": true}                                                                |
| binding:host_id       | rose11.qa.lab.tlv.redhat.com                                                         |
| binding:vif_type      | ovs                                                                                  |
| device_id             | 8e4018ff-5656-422b-9af4-389fc97d4b1e                                                 |
| device_owner          | compute:None                                                                         |
| extra_dhcp_opts       |                                                                                      |
| fixed_ips             | {"subnet_id": "475970ce-badb-4025-9240-854d00cdc83e", "ip_address": "192.168.238.2"} |
| id                    | 8ea7ee3b-42f2-4208-a33a-c20bea6d25f8                                                 |
| mac_address           | fa:16:3e:cf:95:d8                                                                    |
| name                  |                                                                                      |
| network_id            | 992071d2-115f-41a1-9ecd-47147045d586                                                 |
| security_groups       | 99f29033-e186-4a3d-ae89-029a0b4caeca                                                 |
| status                | ACTIVE                                                                               |
| tenant_id             | 80384d55b7554d9ab3d6190142a69d34                                                     |
+-----------------------+--------------------------------------------------------------------------------------+
Comment 9 errata-xmlrpc 2013-12-19 19:15:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.