Bug 989208 - incorrect ConsoleKit obsoletes in mate-desktop
incorrect ConsoleKit obsoletes in mate-desktop
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mate-desktop (Show other bugs)
19
Unspecified Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 07:11 EDT by Kalev Lember
Modified: 2013-07-28 20:26 EDT (History)
4 users (show)

See Also:
Fixed In Version: mate-desktop-1.6.1-10.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-28 20:26:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kalev Lember 2013-07-28 07:11:21 EDT
mate-desktop-1.6.1-9.fc19 added 'Obsoletes: ConsoleKit' to the spec file. The obsoletes cause yum to install mate-desktop as a replacement for ConsoleKit, even on systems that don't have any of MATE installed.

From a yum update log:

---> Package ConsoleKit.x86_64 0:0.4.5-5.fc20 will be obsoleted
---> Package mate-desktop.x86_64 0:1.6.1-9.fc20 will be obsoleting
--> Processing Dependency: mate-desktop-libs(x86-64) = 1.6.1-9.fc20 for package: mate-desktop-1.6.1-9.fc20.x86_64
--> Processing Dependency: mate-panel for package: mate-desktop-1.6.1-9.fc20.x86_64

... and so on, dragging in a bunch of unwanted packages.

The Obsoletes should go to systemd instead (or some other package lower in the stack).
Comment 1 Fedora Update System 2013-07-28 08:36:06 EDT
mate-desktop-1.6.1-10.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mate-desktop-1.6.1-10.fc19
Comment 2 Fedora Update System 2013-07-28 20:26:50 EDT
mate-desktop-1.6.1-10.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.