Bug 989212 - persistent network device names no longer works
persistent network device names no longer works
Status: CLOSED DUPLICATE of bug 989099
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 08:01 EDT by Michal Hlavinka
Modified: 2013-07-28 10:32 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-28 10:32:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Hlavinka 2013-07-28 08:01:05 EDT
Description of problem:
I have monitor-less NAS/router with 4 ethernet NICs. After I updated it to Fedora 19, network interfaces got names in wrong order with "funny" results.

In /etc/udev/rules.d/70-persistent-net.rules I have following:
SUBSYSTEM=="net", ACTION=="add", DRIVERS="?*", ATTR{address}=="00:30:48:da:8d:95", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
SUBSYSTEM=="net", ACTION=="add", DRIVERS="?*", ATTR{address}=="00:30:48:da:8d:94", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"
SUBSYSTEM=="net", ACTION=="add", DRIVERS="?*", ATTR{address}=="00:30:4f:71:98:f2", ATTR{type}=="1", KERNEL=="eth*", NAME="eth2"
SUBSYSTEM=="net", ACTION=="add", DRIVERS="?*", ATTR{address}=="00:30:4f:71:99:1d", ATTR{type}=="1", KERNEL=="eth*", NAME="eth3"

as a result, names are in ethN format, but wrong order:
$ for e in eth{0..3}; do echo -n "$e: "; ifconfig $e | sed -n 's/^.ether \([^ ]*\).*$/\1/p'; done
eth0: 00:30:4f:71:98:f2
eth1: 00:30:4f:71:99:1d
eth2: 00:30:48:da:8d:94
eth3: 00:30:48:da:8d:95

eth0 should be eth2
eth1 should be eth3
eth2 should be eth1
eth3 should be eth0

Version-Release number of selected component (if applicable):
systemd-204-9.fc19.x86_64

How reproducible:
always

Steps to Reproduce:
1.on system with multiple NICs
2.configure persistent names
3.reboot
4.check names

Actual results:
wrong names

Expected results:
names as described in persitent names rules file

Additional info:
this was working in Fedora 17
Comment 1 Michal Hlavinka 2013-07-28 08:09:07 EDT
$ journalctl -b | grep udev
systemd-udevd[194]: error changing net interface name eth0 to eth2: File exists
systemd-udevd[198]: error changing net interface name eth1 to eth3: File exists
systemd-udevd[203]: error changing net interface name eth2 to eth1: File exists
systemd-udevd[202]: error changing net interface name eth3 to eth0: File exists
Comment 2 Kay Sievers 2013-07-28 10:32:58 EDT

*** This bug has been marked as a duplicate of bug 989099 ***

Note You need to log in before you can comment on or make changes to this bug.