Bug 989213 - UI issues in volume popup view
UI issues in volume popup view
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Kanagaraj
SATHEESARAN
gluster
:
Depends On:
Blocks: 1019461 3.3snap4
  Show dependency treegraph
 
Reported: 2013-07-28 08:07 EDT by Yaniv Bronhaim
Modified: 2016-04-18 06:07 EDT (History)
11 users (show)

See Also:
Fixed In Version: is26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:18:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Gluster
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21823 None None None Never

  None (edit)
Description Yaniv Bronhaim 2013-07-28 08:07:34 EDT
Description of problem:
Some UI issues that raised during testing the view:

1. Entering to "Add Bricks" form, adding 2 bricks and deleting the one at the top does't work as expected. The remain brick appears twice with the same name.
2. Cancel button doesn't cancel the bricks configuration. IMHO, it should be  "Back" button.
3. Creating a brick raised "Error while executing action: General command validation failure". IMHO, the information is not enough to work with.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Expected results:
1. The brick should be removed without leftovers.
2. It should cancel all configurations that have been changed when the form was opened.
3. More detailed message.
Comment 1 Dusmant 2013-10-22 00:34:45 EDT
Kanagaraj is going to fix the first issue mentioned.
2nd issue -- We are not going to change the cancel button
3rd issue -- already addressed
Comment 2 SATHEESARAN 2013-12-10 01:42:39 EST
VERIFIED with following versions of RHEVM and RHS

RHEVM - IS26 ( 3.3.0-0.38.rc.el6ev )
RHS   - RHS 2.1 Update 1 ( glusterfs-3.4.0.44rhs-1 )

Steps used for verification :
1. Created a 3.2 POSIXFS Datacenter
2. Created a 3.2 compatible gluster enabled cluster 
3. Added 2 RHSS Nodes, one by one, to the 3.2 gluster-cluster
4. While creating the volume, tried removing brick entries.
5. Tried moving up and moving down the brick entries

Marking this bug as VERIFIED.
Comment 3 Itamar Heim 2014-01-21 17:18:28 EST
Closing - RHEV 3.3 Released
Comment 4 Itamar Heim 2014-01-21 17:24:51 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.