Bug 989237 - [VDSM]Adding new network to Host with gateway configuration causes disconnection to that Host
[VDSM]Adding new network to Host with gateway configuration causes disconnect...
Status: CLOSED DUPLICATE of bug 984028
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
high Severity unspecified
: ---
: 3.3.0
Assigned To: Assaf Muller
GenadiC
network
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 11:26 EDT by GenadiC
Modified: 2016-02-10 14:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 18:27:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm log (14.07 MB, text/x-log)
2013-07-28 11:26 EDT, GenadiC
no flags Details
supervdsm log (5.71 MB, text/x-log)
2013-07-28 11:28 EDT, GenadiC
no flags Details

  None (edit)
Description GenadiC 2013-07-28 11:26:57 EDT
Created attachment 779378 [details]
vdsm log

Description of problem:
If you add network x with gateway configuration to Host that doesn't contain IP rules ( for example upgraded host from 3.2 to 3.3) then Host looses connectivity.
Even after 2 minutes(default value), when the Host is supposed to come back after check connectivity failure it does not as the default gateway configuration is missing in the routing table

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take the host without IP rules configured (for example host upgraded from 3.2)
2. Configure network red and attach it to Host with Static configuration: IP of 1.1.1.1, netmask of 255.255.255.0 and gateway of 1.1.1.254 using setupNetworks
3.

Actual results:
Host looses connectivity and never comes back

Expected results:
Host is not supposed to loose connectivity

Additional info:

After configuring IP rules on the Host everything worked as supposed to.
Comment 1 GenadiC 2013-07-28 11:28:18 EDT
Created attachment 779379 [details]
supervdsm log
Comment 2 Dan Kenigsberg 2013-08-22 18:27:20 EDT
A vdsm bug should never be filed without stating the relevant vdsm version.

I believe that this is a dup of Bug 984028. Please reopen if it reproduces with vdsm that includes

commit 8f4a060cc24901bb64490d8dd359799b1502bf60
Author: Assaf Muller <amuller@redhat.com>
Date:   Thu Aug 1 15:10:05 2013 +0300

    Management network is now kept in main routing table

*** This bug has been marked as a duplicate of bug 984028 ***

Note You need to log in before you can comment on or make changes to this bug.