Bug 989251 - [abrt] WARNING: at net/ipv4/tcp_input.c:2776 tcp_fastretrans_alert+0xc64/0xd00()
[abrt] WARNING: at net/ipv4/tcp_input.c:2776 tcp_fastretrans_alert+0xc64/0xd00()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:69366accfd6e4b7c57b917a60da...
: Reopened
: 996482 1010561 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-07-28 15:01 EDT by Miroslav Jaroš
Modified: 2013-11-12 21:15 EST (History)
44 users (show)

See Also:
Fixed In Version: kernel-3.11.7-100.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 02:55:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (74.52 KB, text/plain)
2013-07-28 15:02 EDT, Miroslav Jaroš
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 60779 None None None Never

  None (edit)
Description Miroslav Jaroš 2013-07-28 15:01:55 EDT
Additional info:
reporter:       libreport-2.1.5
WARNING: at net/ipv4/tcp_input.c:2776 tcp_fastretrans_alert+0xc64/0xd00()
Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables rfcomm bnep acpi_cpufreq mperf coretemp snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device kvm_intel kvm arc4 iwl3945 iwlegacy mac80211 cfg80211 snd_pcm dell_wmi sparse_keymap btusb bluetooth iTCO_wdt iTCO_vendor_support wmi dell_laptop joydev rfkill snd_page_alloc tg3 ptp pps_core dcdbas snd_timer microcode lpc_ich mfd_core snd i2c_i801 soundcore uinput dm_crypt firewire_ohci firewire_core i915 crc_itu_t yenta_socket i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.10.3-300.fc19.x86_64 #1
Hardware name: Dell Inc. Latitude D630                   /0KU184, BIOS A17 01/04/2010
 0000000000000009 ffff88007f403840 ffffffff81643216 ffff88007f403878
 ffffffff8105c211 ffff88007b480e00 0000000000004320 0000000000000001
 0000000000000000 000000000000000b ffff88007f403888 ffffffff8105c2ea
Call Trace:
 <IRQ>  [<ffffffff81643216>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2ea>] warn_slowpath_null+0x1a/0x20
 [<ffffffff8158bf04>] tcp_fastretrans_alert+0xc64/0xd00
 [<ffffffff8158caa8>] tcp_ack+0xa08/0xfd0
 [<ffffffff815c4ed7>] ? ipt_do_table+0x317/0x6b0
 [<ffffffff8158d532>] tcp_rcv_established+0x182/0x8b0
 [<ffffffff815975e4>] tcp_v4_do_rcv+0x1b4/0x470
 [<ffffffff81599956>] tcp_v4_rcv+0x676/0x7c0
 [<ffffffff81573b80>] ? ip_rcv_finish+0x320/0x320
 [<ffffffff8156af94>] ? nf_hook_slow+0x74/0x130
 [<ffffffff81573b80>] ? ip_rcv_finish+0x320/0x320
 [<ffffffff81573c50>] ip_local_deliver_finish+0xd0/0x210
 [<ffffffff81573f27>] ip_local_deliver+0x47/0x80
 [<ffffffff815738d8>] ip_rcv_finish+0x78/0x320
 [<ffffffff8157418f>] ip_rcv+0x22f/0x380
 [<ffffffff8153cb86>] __netif_receive_skb_core+0x646/0x820
 [<ffffffff8153cd78>] __netif_receive_skb+0x18/0x60
 [<ffffffff8153cdf3>] netif_receive_skb+0x33/0xb0
 [<ffffffffa0339b38>] ieee80211_deliver_skb.isra.27+0x98/0x210 [mac80211]
 [<ffffffffa033af4d>] ieee80211_rx_handlers+0xbad/0x20c0 [mac80211]
 [<ffffffff81093be8>] ? __enqueue_entity+0x78/0x80
 [<ffffffffa033c8b4>] ieee80211_prepare_and_rx_handle+0x454/0xa80 [mac80211]
 [<ffffffffa033d1cd>] ieee80211_rx+0x2ed/0x850 [mac80211]
 [<ffffffffa03b2ea9>] il3945_hdl_rx+0x3c9/0x650 [iwl3945]
 [<ffffffff8152ec0e>] ? skb_free_head+0x1e/0x70
 [<ffffffffa03afd36>] il3945_irq_tasklet+0x516/0xbc0 [iwl3945]
 [<ffffffff8108473a>] ? __hrtimer_start_range_ns+0x1ba/0x3e0
 [<ffffffff810647ee>] tasklet_action+0x6e/0x110
 [<ffffffff81064987>] __do_softirq+0xf7/0x240
 [<ffffffff81064c65>] irq_exit+0xb5/0xc0
 [<ffffffff816534d6>] do_IRQ+0x56/0xc0
 [<ffffffff8164952d>] common_interrupt+0x6d/0x6d
 <EOI>  [<ffffffff814f215f>] ? cpuidle_enter_state+0x4f/0xc0
 [<ffffffff814f2158>] ? cpuidle_enter_state+0x48/0xc0
 [<ffffffff814f2299>] cpuidle_idle_call+0xc9/0x210
 [<ffffffff81019e1e>] arch_cpu_idle+0xe/0x30
 [<ffffffff810aa3be>] cpu_startup_entry+0xce/0x280
 [<ffffffff8162d3c7>] rest_init+0x77/0x80
 [<ffffffff81d0bedc>] start_kernel+0x40a/0x416
 [<ffffffff81d0b8db>] ? repair_env_string+0x5c/0x5c
 [<ffffffff81d0b120>] ? early_idt_handlers+0x120/0x120
 [<ffffffff81d0b5da>] x86_64_start_reservations+0x2a/0x2c
 [<ffffffff81d0b6cf>] x86_64_start_kernel+0xf3/0x100
Comment 1 Miroslav Jaroš 2013-07-28 15:02:02 EDT
Created attachment 779404 [details]
File: dmesg
Comment 2 Modhaffer Rahmani 2013-07-28 21:37:59 EDT
Description of problem:
I was mainly browsing the net and using few flash games and apps and streaming a video on facebook untill i got a message telling me that there was a problem with kernel package.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.10.3-300.fc19.x86_64 root=/dev/mapper/VolGroup-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=VolGroup/lv_swap vconsole.keymap=us rd.lvm.lv=VolGroup/lv_root rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8
kernel:         3.10.3-300.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at net/ipv4/tcp_input.c:2776 tcp_fastretrans_alert+0xc64/0xd00()
Modules linked in: fuse ebtable_nat nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack bnep bluetooth rfkill ebtable_filter ebtables ip6table_filter ip6_tables snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq acpi_cpufreq mperf iTCO_wdt iTCO_vendor_support coretemp snd_seq_device snd_pcm snd_page_alloc snd_timer snd lpc_ich mfd_core kvm_intel kvm r8169 soundcore mii i2c_i801 joydev microcode serio_raw binfmt_misc uinput nouveau video mxm_wmi wmi i2c_algo_bit drm_kms_helper ttm drm i2c_core
CPU: 0 PID: 3283 Comm: chrome Not tainted 3.10.3-300.fc19.x86_64 #1
Hardware name: OEM OEM/G31MXP/G31MXP-K, BIOS 6.00 PG 04/10/2009
 0000000000000009 ffff88007fc03a60 ffffffff81643216 ffff88007fc03a98
 ffffffff8105c211 ffff88004a383100 0000000000004320 0000000000000001
 0000000000000000 0000000000000008 ffff88007fc03aa8 ffffffff8105c2ea
Call Trace:
 <IRQ>  [<ffffffff81643216>] dump_stack+0x19/0x1b
 [<ffffffff8105c211>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2ea>] warn_slowpath_null+0x1a/0x20
 [<ffffffff8158bf04>] tcp_fastretrans_alert+0xc64/0xd00
 [<ffffffff8158caa8>] tcp_ack+0xa08/0xfd0
 [<ffffffff815c4ed7>] ? ipt_do_table+0x317/0x6b0
 [<ffffffff8158d532>] tcp_rcv_established+0x182/0x8b0
 [<ffffffff815975e4>] tcp_v4_do_rcv+0x1b4/0x470
 [<ffffffff81599956>] tcp_v4_rcv+0x676/0x7c0
 [<ffffffff81573b80>] ? ip_rcv_finish+0x320/0x320
 [<ffffffff8156af94>] ? nf_hook_slow+0x74/0x130
 [<ffffffff81573b80>] ? ip_rcv_finish+0x320/0x320
 [<ffffffff81573c50>] ip_local_deliver_finish+0xd0/0x210
 [<ffffffff81573f27>] ip_local_deliver+0x47/0x80
 [<ffffffff815738d8>] ip_rcv_finish+0x78/0x320
 [<ffffffff8157418f>] ip_rcv+0x22f/0x380
 [<ffffffff8153cb86>] __netif_receive_skb_core+0x646/0x820
 [<ffffffff8153cd78>] __netif_receive_skb+0x18/0x60
 [<ffffffff8153cdf3>] netif_receive_skb+0x33/0xb0
 [<ffffffff8153d7d0>] napi_gro_receive+0x80/0xb0
 [<ffffffffa01d302c>] rtl8169_poll+0x16c/0x668 [r8169]
 [<ffffffff8153d169>] net_rx_action+0x149/0x240
 [<ffffffff81064987>] __do_softirq+0xf7/0x240
 [<ffffffff81064c65>] irq_exit+0xb5/0xc0
 [<ffffffff816534d6>] do_IRQ+0x56/0xc0
 [<ffffffff8164952d>] common_interrupt+0x6d/0x6d
 <EOI>
Comment 3 Dave Jones 2013-07-30 00:04:46 EDT
I think this is fixed with this patch.
http://permalink.gmane.org/gmane.linux.network/276871

In the meantime, you should be able to work around it by setting these sysctls:

net.ipv4.tcp_frto=0
net.ipv4.tcp_early_retrans=3
Comment 4 Josh Boyer 2013-08-15 10:01:32 EDT
*** Bug 996482 has been marked as a duplicate of this bug. ***
Comment 5 Martí­n Marqués 2013-08-16 11:04:11 EDT
What's the downside of setting those 2 sysctrl settings?
Comment 6 Martí­n Marqués 2013-08-17 18:06:31 EDT
(In reply to Dave Jones from comment #3)
> I think this is fixed with this patch.
> http://permalink.gmane.org/gmane.linux.network/276871
> 
> In the meantime, you should be able to work around it by setting these
> sysctls:
> 
> net.ipv4.tcp_frto=0
> net.ipv4.tcp_early_retrans=3

This didn't work.
Comment 7 wintonian 2013-08-24 14:21:15 EDT
I think the latest kernel update (3.10.9-200.fc19.x86_64) might of made things worse, I am now receiving the error every few minutes.
Comment 8 Martí­n Marqués 2013-08-26 12:28:43 EDT
Has this issue been take upstream?
Comment 9 mahmoodkamal 2013-09-10 08:03:35 EDT
Description of problem:
i don't know. I am only using Firefox 23 at the moment alongwith Thunar file manager. 

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.6
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.10.10-200.fc19.i686 root=UUID=c81ad2b1-bde9-45b0-8c8c-ea07a3f67aa2 ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 vconsole.keymap=us rhgb quiet LANG=en_US.UTF-8
kernel:         3.10.10-200.fc19.i686
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at net/ipv4/tcp_input.c:2776 tcp_fastretrans_alert+0xac8/0xb60()
Modules linked in: michael_mic arc4 lib80211_crypt_tkip lib80211_crypt_ccmp nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables btrfs zlib_deflate raid6_pq libcrc32c xor gpio_ich iTCO_wdt iTCO_vendor_support dell_laptop dcdbas acpi_cpufreq mperf snd_intel8x0 snd_intel8x0m snd_ac97_codec ac97_bus snd_seq snd_seq_device snd_pcm ipw2200 b44 ssb libipw microcode sdhci_pci cfg80211 sdhci joydev snd_page_alloc snd_timer lpc_ich btusb lib80211 snd mmc_core mii soundcore bluetooth rfkill binfmt_misc i915 i2c_algo_bit firewire_ohci drm_kms_helper firewire_core drm yenta_socket crc_itu_t i2c_core video
CPU: 0 PID: 1410 Comm: plugin-containe Not tainted 3.10.10-200.fc19.i686 #1
Hardware name: Dell Inc. Inspiron 6000                   /0J5165, BIOS A09 09/28/2005
 00000000 00000000 f208bc50 c096818a f208bc78 c043d6ae c0af89ea c0b70d36
 00000ad8 c08c41f8 c08c41f8 f2219f80 00000000 0000452e f208bc88 c043d772
 00000009 00000000 f208bcc4 c08c41f8 51b433f2 f2219f80 f208bcc4 c08f748c
Call Trace:
 [<c096818a>] dump_stack+0x16/0x18
 [<c043d6ae>] warn_slowpath_common+0x5e/0x80
 [<c08c41f8>] ? tcp_fastretrans_alert+0xac8/0xb60
 [<c08c41f8>] ? tcp_fastretrans_alert+0xac8/0xb60
 [<c043d772>] warn_slowpath_null+0x22/0x30
 [<c08c41f8>] tcp_fastretrans_alert+0xac8/0xb60
 [<c08f748c>] ? bictcp_cong_avoid+0x4c/0x400
 [<c08c4306>] ? tcp_rearm_rto+0x76/0x100
 [<c08c4d0d>] tcp_ack+0x97d/0xe30
 [<c08c560e>] tcp_rcv_established+0x14e/0x7b0
 [<c08ce8e3>] tcp_v4_do_rcv+0x153/0x3e0
 [<c0610824>] ? security_sock_rcv_skb+0x14/0x20
 [<c08d0830>] tcp_v4_rcv+0x5e0/0x6f0
 [<c08a6ca5>] ? nf_iterate+0x75/0x80
 [<c08ae3b0>] ? ip_rcv_finish+0x320/0x320
 [<c08ae44a>] ip_local_deliver_finish+0x9a/0x230
 [<c08ae71c>] ip_local_deliver+0x3c/0x80
 [<c08ae3b0>] ? ip_rcv_finish+0x320/0x320
 [<c08ae0f0>] ip_rcv_finish+0x60/0x320
 [<c08ae9a8>] ip_rcv+0x248/0x3a0
 [<c08ae090>] ? inet_del_offload+0x30/0x30
 [<c087ed2f>] __netif_receive_skb_core+0x51f/0x700
 [<c087ef26>] __netif_receive_skb+0x16/0x60
 [<c087f894>] process_backlog+0x84/0x140
 [<c087f278>] net_rx_action+0x118/0x1f0
 [<c0445829>] __do_softirq+0xc9/0x1e0
 [<c04270cf>] ? ack_apic_level+0x5f/0xf0
 [<c04bad00>] ? handle_irq_event_percpu+0xf0/0x1a0
 [<c0445aa5>] irq_exit+0x95/0xa0
 [<c0403b85>] do_IRQ+0x45/0xb0
 [<c04ad0e6>] ? __audit_syscall_exit+0x1c6/0x260
 [<c0975073>] common_interrupt+0x33/0x38
 [<c0960000>] ? setup_local_APIC+0x3d1/0x3d1
Comment 10 Michele Baldessari 2013-09-10 17:50:22 EDT
It's been reported upstream:
https://bugzilla.kernel.org/show_bug.cgi?id=60779
Comment 11 Blotto 2013-09-11 03:43:45 EDT
Description of problem:
Using web browser and P2P download software.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.10.10-200.fc19.x86_64 root=UUID=8fe81744-33e7-43b8-93ec-de22d9a1cc9c ro rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=us rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet LANG=en_US.UTF-8
kernel:         3.10.10-200.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at net/ipv4/tcp_input.c:2776 tcp_fastretrans_alert+0xc64/0xd00()
Modules linked in: tcp_lp fuse ebtable_nat rfcomm bnep nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables snd_hda_codec_hdmi arc4 brcmsmac cordic brcmutil mac80211 snd_hda_codec_idt snd_hda_intel mperf coretemp snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd cfg80211 soundcore kvm_intel btusb bluetooth kvm crc32_pclmul crc32c_intel ghash_clmulni_intel ums_realtek rfkill iTCO_wdt iTCO_vendor_support dell_wmi sparse_keymap usb_storage dell_laptop dcdbas uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev microcode i2c_i801 media bcma joydev lpc_ich mfd_core mei_me r8169 mei mii wmi binfmt_misc uinput i915 i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 1 PID: 5102 Comm: chrome Not tainted 3.10.10-200.fc19.x86_64 #1
Hardware name: Dell Inc. Vostro 1450/0KGFK0, BIOS A08 08/03/2012
 0000000000000009 ffff880100303948 ffffffff81639647 ffff880100303980
 ffffffff8105c221 ffff880056343100 0000000000004900 0000000000000001
 0000000000000001 0000000000000002 ffff880100303990 ffffffff8105c2fa
Call Trace:
 <IRQ>  [<ffffffff81639647>] dump_stack+0x19/0x1b
 [<ffffffff8105c221>] warn_slowpath_common+0x61/0x80
 [<ffffffff8105c2fa>] warn_slowpath_null+0x1a/0x20
 [<ffffffff81582394>] tcp_fastretrans_alert+0xc64/0xd00
 [<ffffffff81582f38>] tcp_ack+0xa08/0xfd0
 [<ffffffff815bb367>] ? ipt_do_table+0x317/0x6b0
 [<ffffffff815839c2>] tcp_rcv_established+0x182/0x8b0
 [<ffffffff8158da74>] tcp_v4_do_rcv+0x1b4/0x470
 [<ffffffff8158fde6>] tcp_v4_rcv+0x676/0x7c0
 [<ffffffff8156a010>] ? ip_rcv_finish+0x320/0x320
 [<ffffffff81561424>] ? nf_hook_slow+0x74/0x130
 [<ffffffff8156a010>] ? ip_rcv_finish+0x320/0x320
 [<ffffffff8156a0e0>] ip_local_deliver_finish+0xd0/0x210
 [<ffffffff8156a3b7>] ip_local_deliver+0x47/0x80
 [<ffffffff81569d68>] ip_rcv_finish+0x78/0x320
 [<ffffffff8156a61f>] ip_rcv+0x22f/0x380
 [<ffffffff81533006>] __netif_receive_skb_core+0x646/0x820
 [<ffffffff815331f8>] __netif_receive_skb+0x18/0x60
 [<ffffffff81533273>] netif_receive_skb+0x33/0xb0
 [<ffffffffa0475b58>] ieee80211_deliver_skb.isra.27+0x98/0x210 [mac80211]
 [<ffffffffa0476f6d>] ieee80211_rx_handlers+0xbad/0x20c0 [mac80211]
 [<ffffffff81522b10>] ? build_skb+0x30/0x1d0
 [<ffffffff81524e09>] ? __netdev_alloc_skb+0x89/0xf0
 [<ffffffffa04788f8>] ieee80211_prepare_and_rx_handle+0x478/0xab0 [mac80211]
 [<ffffffffa0475741>] ? ieee80211_rx_irqsafe+0x41/0x50 [mac80211]
 [<ffffffffa047921d>] ieee80211_rx+0x2ed/0x850 [mac80211]
 [<ffffffffa0459161>] ieee80211_tasklet_handler+0xc1/0xd0 [mac80211]
 [<ffffffff810647fe>] tasklet_action+0x6e/0x110
 [<ffffffff81064997>] __do_softirq+0xf7/0x240
 [<ffffffff81064c75>] irq_exit+0xb5/0xc0
 [<ffffffff81649916>] do_IRQ+0x56/0xc0
 [<ffffffff8163f96d>] common_interrupt+0x6d/0x6d
 <EOI>
Comment 12 Josh Boyer 2013-09-11 21:51:10 EDT
(In reply to Martí­n Marqués from comment #8)
> Has this issue been take upstream?

It has.  The upstream developer said:

"since frto=0 didn't help, I suspect it's either a bug introduced in
the tail loss probe patch 9b717a8d (tcp: TLP loss detection) or other
changes related loss recovery.

could you try disable TLP by
sysctl net.ipv4.tcp_frto=0 net.ipv4.tcp_early_retrans=1

if it still does not work. disable any form of early retransmit by
sysctl net.ipv4.tcp_frto=0 net.ipv4.tcp_early_retrans=0"

Please try those steps and let us know what you see.

There is also a debug patch provided and I will get a scratch build done tomorrow with that included.
Comment 13 Josh Boyer 2013-09-18 16:41:13 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 14 Josh Boyer 2013-09-23 14:06:07 EDT
*** Bug 1010561 has been marked as a duplicate of this bug. ***
Comment 15 Martí­n Marqués 2013-09-27 14:20:01 EDT
Setting net.ipv4.tcp_early_retrans=1 made my VPN connection stop working.

Connection finished, but I couldn't pin through the VPN, so I went back to the value of 3.
Comment 16 michelenani 2013-09-28 15:30:10 EDT
Description of problem:
I was writing on libreoffice write, with dropbox on and aMule working, no more else.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.10.10-100.fc18.i686.PAE root=UUID=88609fa1-989e-45cf-b45c-ab19489f2560 ro LANG=it_IT.UTF-8 rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=it
kernel:         3.10.10-100.fc18.i686.PAE
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at net/ipv4/tcp_input.c:2776 tcp_fastretrans_alert+0xad6/0xb70()
Modules linked in: usblp fuse ip6t_REJECT nf_conntrack_ipv4 nf_conntrack_ipv6 nf_defrag_ipv4 nf_defrag_ipv6 xt_conntrack ip6table_filter nf_conntrack ip6_tables iTCO_wdt iTCO_vendor_support acpi_cpufreq mperf coretemp kvm nfsd r8169 mii mei_me mei lpc_ich i2c_i801 snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_page_alloc snd_timer snd mfd_core auth_rpcgss soundcore microcode serio_raw nfs_acl lockd uinput sunrpc usb_storage radeon i2c_algo_bit drm_kms_helper ttm crc32_pclmul crc32c_intel drm i2c_core
CPU: 0 PID: 0 Comm: swapper/0 Not tainted 3.10.10-100.fc18.i686.PAE #1
Hardware name: Hewlett-Packard p6-2045it/2ABF, BIOS 7.13 09/28/2011
 00000000 00000000 c0bedb18 c099ad86 c0bedb40 c044bcb4 c0b3183a c0baaca2
 00000ad8 c08f4616 c08f4616 d689e900 00004320 00000000 c0bedb50 c044bcf2
 00000009 00000000 c0bedbb0 c08f4616 00000000 d689edbc 000493e0 d8b2ca5f
Call Trace:
 [<c099ad86>] dump_stack+0x16/0x18
 [<c044bcb4>] warn_slowpath_common+0x64/0x80
 [<c08f4616>] ? tcp_fastretrans_alert+0xad6/0xb70
 [<c08f4616>] ? tcp_fastretrans_alert+0xad6/0xb70
 [<c044bcf2>] warn_slowpath_null+0x22/0x30
 [<c08f4616>] tcp_fastretrans_alert+0xad6/0xb70
 [<c08f4726>] ? tcp_rearm_rto+0x76/0x100
 [<c08f513d>] tcp_ack+0x98d/0xe10
 [<c08f5b64>] tcp_rcv_established+0x244/0x800
 [<c08ff2a3>] tcp_v4_do_rcv+0x233/0x3f0
 [<c062cc44>] ? security_sock_rcv_skb+0x14/0x20
 [<c0900eb7>] tcp_v4_rcv+0x627/0x730
 [<c08d6c3a>] ? nf_iterate+0x6a/0x90
 [<c08de5a0>] ? ip_rcv_finish+0x320/0x320
 [<c08d6cbc>] ? nf_hook_slow+0x5c/0x100
 [<c08de63a>] ip_local_deliver_finish+0x9a/0x230
 [<c08de90c>] ip_local_deliver+0x3c/0x80
 [<c08de5a0>] ? ip_rcv_finish+0x320/0x320
 [<c08de2e0>] ip_rcv_finish+0x60/0x320
 [<c08deb97>] ip_rcv+0x247/0x3b0
 [<c08de280>] ? inet_add_protocol+0x50/0x50
 [<c08ae40b>] __netif_receive_skb_core+0x56b/0x6f0
 [<c08ae5ad>] __netif_receive_skb+0x1d/0x60
 [<c08ae75e>] netif_receive_skb+0x2e/0x90
 [<c08aefff>] napi_gro_receive+0x7f/0xb0
 [<f80e0578>] rtl8169_poll+0x138/0x520 [r8169]
 [<c0414750>] ? alternatives_smp_module_add+0x140/0x140
 [<c08aed5d>] net_rx_action+0x11d/0x1f0
 [<c0453b53>] __do_softirq+0xc3/0x1f0
 [<c049ecfa>] ? tick_do_update_jiffies64+0xca/0x130
 [<c0453de5>] irq_exit+0x95/0xa0
 [<c0410fbb>] do_IRQ+0x4b/0xc0
 [<c09a7ab3>] common_interrupt+0x33/0x38
 [<c049007b>] ? saveable_highmem_page+0x3b/0x90
 [<c08704b6>] ? cpuidle_enter_state+0x46/0xd0
 [<c08705d4>] cpuidle_idle_call+0x94/0x1d0
 [<c0416dfd>] arch_cpu_idle+0xd/0x30
 [<c049508d>] cpu_startup_entry+0x8d/0x210
 [<c09877d2>] rest_init+0x62/0x70
 [<c0c79ac3>] start_kernel+0x397/0x39d
 [<c0c79561>] ? repair_env_string+0x51/0x51
 [<c0c7938c>] i386_start_kernel+0x12f/0x132
Comment 17 Michele Baldessari 2013-10-14 03:24:15 EDT
FWIW: The following patch has been proposed upstream

Reported-By: Michael Sterrett <michael@sterretts.net>
Tested-By: Dormando <dormando@rydia.net>
Signed-off-by: Yuchung Cheng <ycheng@google.com>
---
 net/ipv4/tcp_input.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/ipv4/tcp_input.c b/net/ipv4/tcp_input.c
index 113dc5f..53974c7 100644
--- a/net/ipv4/tcp_input.c
+++ b/net/ipv4/tcp_input.c
@@ -3291,7 +3291,7 @@ static void tcp_process_tlp_ack(struct sock *sk, u32 ack, int flag)
                        tcp_init_cwnd_reduction(sk, true);
                        tcp_set_ca_state(sk, TCP_CA_CWR);
                        tcp_end_cwnd_reduction(sk);
-                       tcp_set_ca_state(sk, TCP_CA_Open);
+                       tcp_try_keep_open(sk);
                        NET_INC_STATS_BH(sock_net(sk),
                                         LINUX_MIB_TCPLOSSPROBERECOVERY);
                }
Comment 18 Josh Boyer 2013-10-15 17:19:51 EDT
Thanks for following up there.  I'll try and get the patch included tomorrow.

http://thread.gmane.org/gmane.linux.network/286793
Comment 19 Josh Boyer 2013-10-22 10:27:02 EDT
Added to Fedora git now.  My apologies for the delay in getting this in.
Comment 20 Fedora Update System 2013-11-02 15:14:27 EDT
kernel-3.11.6-302.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.6-302.fc20
Comment 21 Fedora Update System 2013-11-02 15:21:01 EDT
kernel-3.11.6-201.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.11.6-201.fc19
Comment 22 Fedora Update System 2013-11-02 15:24:29 EDT
kernel-3.11.6-101.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.11.6-101.fc18
Comment 23 Fedora Update System 2013-11-03 00:35:34 EDT
Package kernel-3.11.6-101.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.6-101.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20545/kernel-3.11.6-101.fc18
then log in and leave karma (feedback).
Comment 24 Fedora Update System 2013-11-04 15:16:43 EST
kernel-3.11.7-300.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.11.7-300.fc20
Comment 25 Fedora Update System 2013-11-04 15:20:19 EST
kernel-3.11.7-100.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.11.7-100.fc18
Comment 26 Fedora Update System 2013-11-04 21:58:47 EST
kernel-3.11.6-201.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2013-11-05 15:03:10 EST
Package kernel-3.11.7-300.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.11.7-300.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-20705/kernel-3.11.7-300.fc20
then log in and leave karma (feedback).
Comment 28 Fedora Update System 2013-11-10 02:55:10 EST
kernel-3.11.7-300.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 29 Fedora Update System 2013-11-12 21:15:03 EST
kernel-3.11.7-100.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.