Bug 9894 - some (non linux) systems have broken glob() functions which break rpm
Summary: some (non linux) systems have broken glob() functions which break rpm
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-01 16:18 UTC by Nigel Metheringham
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-13 10:54:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nigel Metheringham 2000-03-01 16:18:09 UTC
solaris 2.6 (spit) has a broken glob call which cannot detect
dangling symlinks.  eg

%install
...
ln -s /some/place $RPM_BUILD_ROOT/etc/cron.daily/
...

%files
/etc/cron.daily/*

Solaris 2.6 has a glob which is detected by autoconf.
However in the case above it fails to expand /etc/cron.daily/*
and the build fails.  [using a relative link works round the
problem since then they are normally within the package].

Although this doesn't affect RHL, and is pretty small potatoes to
rpm, having an easy means in autoconf to shut out the system
glob could be useful.
Also, if config.cache is hacked to say that <glob.h> and glob()
do not exist on the system, the build attempts to make misc/glob.o
and fails due to the #undef of half the useful defines from misc/glob.h
:-)

Comment 1 Jeff Johnson 2000-03-01 17:16:59 UTC
Ah, thanks for identifying. BTW, solaris2.6 also has trouble with
	/usr/*/local/*/LC_MESSAGES/rpm.mo

I anticipate re-adding GNU glob to rpm and always using, although
for slightly different reasons. The latest GNU glob provides private
vectors for opendir/readdir/closedir/stat/lstat that will be used to
implement transport independent remote globbing.

Comment 2 Jeff Johnson 2000-04-13 10:54:59 UTC
GNU glob has been internalized in rpm-3.0.4.


Note You need to log in before you can comment on or make changes to this bug.